Announcement

Collapse
No announcement yet.

Linker Error: Undefined symbols for architecture x86_64 while packaging

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Linker Error: Undefined symbols for architecture x86_64 while packaging

    Hey everyone,

    I'm having some trouble while packaging a project on Mac. It compiles fine as dev editor on both Windows and Mac, and it packages fine on Windows, but the Mac is getting this error when packaging:
    Code:
        [1/5] Link Dwarrows
         Undefined symbols for architecture x86_64:
         "_OBJC_CLASS_$_MTLCaptureManager", referenced from:
         objc-class-ref in UE4-MetalRHI.a(Module.MetalRHI.cpp.o)

    I've tried adding MetalRHI, RHI, and RenderCore to my .Build.cs file and #include "MetalRHI.h" in the file that uses RHI, but neither helped.

    Does anyone have an idea what else I could try?
    Cheers!
    Last edited by Grogger; 12-07-2017, 06:04 PM.

    #2
    I haven't been able to make any headway on this yet, I could use some ideas if you've got them!

    Comment


      #3
      I'm having the same issue:

      UATHelper: Packaging (Mac): Undefined symbols for architecture x86_64:
      UATHelper: Packaging (Mac): "_OBJC_CLASS_$_MTLCaptureManager", referenced from:
      UATHelper: Packaging (Mac): objc-class-ref in UE4-MetalRHI.a(Module.MetalRHI.cpp.o)
      UATHelper: Packaging (Mac): ld: symbol(s) not found for architecture x86_64

      MacOS Sierra 10.12.6 XCode 8.3.3 & UE4 4.18.1

      Comment

      Working...
      X