Announcement

Collapse
No announcement yet.

IgnoreActorWhenMoving behaving different from PhysX

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IgnoreActorWhenMoving behaving different from PhysX

    I'm fairly new to unreal but to not game dev (16 years exp). I have used PhysX directly in my own engine code (and other engines with PhysX), so I know there is a physics ignore actors functionality. The UE4 IgnoreActorWhenMoving does not seem to work.

    For my test, I'm spawning an Actor (shield) with Instigator, and setting IgnoreActorWhenMoving on the instigator EventBeingPlay. That does not work at all but I see stepping through the blueprint, the instigator is set correctly.

    Click image for larger version

Name:	1.jpg
Views:	1
Size:	186.4 KB
ID:	1220055

    Click image for larger version

Name:	2.jpg
Views:	1
Size:	192.9 KB
ID:	1220056


    I seen other proposed "hacks" but they don't work in my situation

    1. use collision layers to ignore collision.
    This only works for single player games. It does not work for multiplayer games or with AI, and I really just want to ignore my spawned actor with the instigator only.

    2. Setting delay to create the collision.
    Does not work on a shield I attach to follow my character. For shields like this

    Click image for larger version

Name:	lZeSPmA.png
Views:	1
Size:	761.1 KB
ID:	1220057

    3. Disable physics.
    Err, what if I want my projectile to have physics behavior like a ballistic? Not a bouncing effect in projectcomponent.

    I'm using 4.15.2, I seen dated thread back to 2014 that have same issues but no proper resolution. Am I missing an API somewhere Is there really no proper for ignore actor (in C++ is fine) or this seems to be a terrible bug/limitation?
    Last edited by overreal; 05-12-2017, 12:43 AM.

    #2
    I think that both actor that are colliding should ignore each others, and not just the spawned one, but I could be wrong

    Comment

    Working...
    X