Announcement

Collapse
No announcement yet.

Can't click buttons

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't click buttons

    Hi. I have a huge problem after updating engine to version 4.14. When I press "play" in editor, I can click all buttons, but only if I don't click on background first. If I click on background, I can't click any button.

    If I build game and run exe without editor, I can't click buttons even if I don't click on backgroud.

    Help please
    English is NOT my native language, so if I do an error - don't eat me

    #2
    try to use node "set input mode UI only"

    Comment


      #3
      Thank you, it fixed problem! But now I have another one. If I open a widget during gameplay via button (e.g. E), I can't close this widget with buttons. I have to set "set input mode UI and game", but then mouse is flickering when I click somewhere. I tried overriding "OnKeyDown" with widget, but it's not working.
      English is NOT my native language, so if I do an error - don't eat me

      Comment


        #4
        Originally posted by Chydzim View Post
        Thank you, it fixed problem! But now I have another one. If I open a widget during gameplay via button (e.g. E), I can't close this widget with buttons. I have to set "set input mode UI and game", but then mouse is flickering when I click somewhere. I tried overriding "OnKeyDown" with widget, but it's not working.
        Post bp screen, ill check it out

        Comment


          #5
          Click image for larger version

Name:	Bez tytułu.png
Views:	1
Size:	245.6 KB
ID:	1117583

          I hope u can read text on this screen

          @edit

          I see I have next problem. I can't select many widgets during editing and assets in content browser. I can do it only with CTRL (not with mouse), but it's not comfortable.
          Last edited by Chydzim; 10-27-2016, 11:34 AM.
          English is NOT my native language, so if I do an error - don't eat me

          Comment


            #6
            R e f r e s h
            English is NOT my native language, so if I do an error - don't eat me

            Comment


              #7
              The 4.14 just went out so it's hard to know if you're not just facing unstability issues. You should head back to 4.13.1 or 4.12.5 if you would like to dive deeper into the learning process and less into the debugging one.
              [Released] Multiplayer Combat Editor
              A-RPG Sacred Swords
              Auto-Chess Live Development
              Youtube Tutorials

              Comment


                #8
                I can't... I converted my project to version 4.14 and I did many changes in it.
                English is NOT my native language, so if I do an error - don't eat me

                Comment


                  #9
                  R e f r e s h
                  English is NOT my native language, so if I do an error - don't eat me

                  Comment


                    #10
                    Originally posted by Chydzim View Post
                    I see I have next problem. I can't select many widgets during editing and assets in content browser. I can do it only with CTRL (not with mouse), but it's not comfortable.
                    I had this issue recently, and it turned out I had to wire the Get Player Controller also into the Create Widget node, for Owning Player.
                    [LEGENDS of EPICA]

                    Comment

                    Working...
                    X