Announcement

Collapse
No announcement yet.

hey new to unreal trying to follow a nice tutorial so far. Question on the bp code.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    hey new to unreal trying to follow a nice tutorial so far. Question on the bp code.

    hey everyone,

    Just wanted to firstly say hi to the community. I have been a mostly unity developer for some time now and recently really have dove in and started to try and learn the engine. I started with learning some of the editing and terain post processing etc. stuff that you could do and i have to admit its absolutly breath taking..

    Onto my question.. the blue print visual scripting is really a neat idea. I am used to actually programming and writing it out. I decided to follow a few basic tutorials first and I am now in the mids of following a tutorial on a crafting and inventory system. For some reason I am running into an error that I am not quiet sure I understand as it appears to be what the video is saying to do. I thought i understood the error warning as i have seen the same one many times in actual programming but for some reason i am not quiet grasping how i can adjust it and fix it. The Error message is as follows.. "Binding: Property ' TextDelegate ' on Widget' TexBlock_1 ' : Member: itemNameTesxtGetter has the wrong number of arguments, it needs to return 1 value an take no parameters. This in itself feels like a very simple fix.. this is why i am getting a bit frustrated that as a programmer i can not work out why its throwing the issue. here is a picture of the visue code i am using and i am almost positive it is exactly what is shown in the video. My concern is that i am using 4.12 and the tuytorial was done in version 4.7 i belive it was. so i think that there might just be a new way i am suppose to wire this up. Anyways, any help would be much appreciated. Thank you one and all and i hope your having a great day

    Link to image: https://s26.postimg.org/c11wr1nhl/un...shot_error.jpg thank you very much!
    \

    edit: the issue appears to be with the added inventory added clicked target. when its removed it appears to compile fine.

    edit: er... it did now it is no longer working without that piece.. hmm
    Last edited by frogman210; 08-15-2016, 06:42 PM.

    #2
    It looks like your return node has one too many return values? I've never seen this error before but try removing the return value that you're not using, the string variable 'Item Name'.

    Comment


      #3
      String to Text conversions can be invalid some times.
      Whats your Item Name Value in the struct?
      @CarstenZarbock - Follow me on Twitter, thank you

      Comment


        #4
        ItemName is what the name is in the struct.

        Comment


          #5
          ok thanks, i will give that a shot. Appreciate the help i know its probably a pretty basic and easy fix to what i am mixing up. Really enjoying the engine so far. The community seems kind as well so that is good to see

          Comment

          Working...
          X