Announcement

Collapse
No announcement yet.

Cant' Join Session

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cant' Join Session

    Hello when launching in the editor with 2 players in new windows I am unable to join a LAN session. I followed the blueprint multiplayer tutorial and have tried a ton of other things such as opening up 7777 in the router etc.

    This is the log when the server host the game and moves to the lobby. The second the server host the game I get client disconnected messages. Any clue how to get join LAN session working on a single computer?

    LogNet: GameNetDriver IpNetDriver_7 IpNetDriver listening on port 7777
    LogWorld: Bringing World /Game/MOBA/Maps/UEDPIE_1_Lobby.Lobby up for play (max tick rate 0) at 2016.08.04-08.54.48
    LogWorld: Bringing up level for play took: 0.003023
    LogOnline:Warning: NULL: Can't start an online session (Game) in state InProgress
    LogLoad: Took 0.180617 seconds to LoadMap(/Game/MOBA/Maps/Lobby)
    LogNet:Warning: Network Failure: GameNetDriver[FailureReceived]: Host closed the connection.
    LogNet:Warning: Network Failure: GameNetDriver[FailureReceived]: Host closed the connection.
    LogNet: NetworkFailure: FailureReceived, Error: 'Host closed the connection.'
    LogBlueprintUserMessages: [GameInfoInstance_C_5] Client 1: ENetworkFailure::FailureReceived
    LogNet: UNetConnection::Close: [UNetConnection] RemoteAddr: 127.0.0.1:7777, Name: IpConnection_4, Driver: GameNetDriver IpNetDriver_6, IsServer: NO, PC: PlayerController_1, Owner: PlayerController_1, Channels: 11, Time: 2016.08.04-15.54.48
    LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 127.0.0.1:7777, Name: IpConnection_4, Driver: GameNetDriver IpNetDriver_6, IsServer: NO, PC: PlayerController_1, Owner: PlayerController_1
    LogNet:Warning: Network Failure: GameNetDriver[ConnectionLost]: Your connection to the host has been lost.
    LogNet:Warning: Network Failure: GameNetDriver[ConnectionLost]: Your connection to the host has been lost.
    LogNet: NetworkFailure: ConnectionLost, Error: 'Your connection to the host has been lost.'
    LogBlueprintUserMessages: [GameInfoInstance_C_5] Client 1: ENetworkFailure::ConnectionLost
    LogNet: NotifyAcceptingConnection: Server Lobby accept
    LogNet: NotifyAcceptingConnection: Server Lobby accept
    LogNet: Browse: /Game/MOBA/Maps/MainMenu?closed
    LogNet: Failed; returning to Entry
    LogLoad: LoadMap: /Game/MOBA/Maps/MainMenu?closed
    LogNet: World NetDriver shutdown IpNetDriver_6 [GameNetDriver]
    LogNet: DestroyNamedNetDriver IpNetDriver_6 [GameNetDriver]
    LogExit: GameNetDriver IpNetDriver_6 shut down
    Last edited by hard_code; 08-04-2016, 12:22 PM.

    #2
    Having the same issue many years later anyone got a solution for this? Cheers.

    Originally posted by jaran View Post
    Hello when launching in the editor with 2 players in new windows I am unable to join a LAN session. I followed the blueprint multiplayer tutorial and have tried a ton of other things such as opening up 7777 in the router etc.

    This is the log when the server host the game and moves to the lobby. The second the server host the game I get client disconnected messages. Any clue how to get join LAN session working on a single computer?

    Comment


      #3
      Originally posted by topper3333 View Post
      Having the same issue many years later anyone got a solution for this? Cheers.
      I too still have this issue -_-.
      Portfolio/Tutorials: http://chadreddick.com

      Comment

      Working...
      X