Announcement

Collapse
No announcement yet.

Swipe bug that's driving me crazy - works when playing from BP, not in editor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Swipe bug that's driving me crazy - works when playing from BP, not in editor

    So I'm trying to do a swipe, in fact I've done this several times and I always end up encountering this error and getting frustrated because of it

    Here's what I do. On touch pressed (mouse click), I get the touch location and save that as a variable, then I open a gate that every tick prints the current mouse location.

    Here's the quantum kicker. If I click play from the blueprint to watch my BP, it works fine.

    if I click play from the level, it doesn't work at all.

    Video:



    When I click play from inside the BP For my pawn, it works as expected - saves and prints the starting screen location of the mouse/touch, and then prints the current location every tick.

    When I click play from the level (and it ABSOLUTELY IS loading the right pawns/controllers, I've done this from a blank project) it ONLY PRINTS the starting location.

    That doesn't even make sense. I am telling it to print the mouses current location, and it prints the starting location that I originally set.

    This is driving me nuts. It works perfect when I launch from the BP!

    Edit: This is nuts.. if I move my blueprint screen for the pawn to my other monitor it doesn't work. Put it back attached to the main UE4 screen and it does.

    Edit Edit:


    This bug is easily reproducible. In fact, the issue is "Moved" doesn't work at all for touch, at least from mouse.

    How to reproduce: Start new mobile project. Enable mouse cursor. Add touch node. Released works properly, gets accurate location. Moved does nothing when playing from primary editor window. If playing from the pawn or PC it works fine.

    Seriously annoying glitch!
    Last edited by Pinworm; 07-21-2016, 03:03 AM.
Working...
X