Announcement

Collapse
No announcement yet.

Can't seem to edit gamemode blueprint.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't seem to edit gamemode blueprint.

    I'm trying to disable my third person character and switch to spectator mode. I checked "start player in spectator mode" , compiled and saved yet that didn't do the trick. I even tried to change the default pawn class to a spectator pawn, but nothing as well. Am I doing something wrong, or is this blueprint not applying to my game for some reason?

    I'm using the third person starter blueprint by the way, and 4.11.2

    Any insight would be greatly appreciated. =)

    Caldera Entertainment | Twitter | ArtStation

    #2
    If you check "Start Player in spectator Mode", it will start as spectator only if you enable "Delayed Start", inside gamemode, afaIk.

    It should work if you just change the default pawn class to spectator.

    Check inside the level if there's some instance of the third person character and delete it. Then try again.

    Comment


      #3
      Originally posted by Gbr View Post
      If you check "Start Player in spectator Mode", it will start as spectator only if you enable "Delayed Start", inside gamemode, afaIk.

      It should work if you just change the default pawn class to spectator.

      Check inside the level if there's some instance of the third person character and delete it. Then try again.
      Hey Gbr!

      It seems it was indeed due to the character being in the level, I was still in the default map from the template. Thanks for the assistance =)

      Caldera Entertainment | Twitter | ArtStation

      Comment


        #4
        Originally posted by SE_JonF View Post
        Hey Gbr!

        It seems it was indeed due to the character being in the level, I was still in the default map from the template. Thanks for the assistance =)
        Nice! You are welcome

        Comment

        Working...
        X