Announcement

Collapse
No announcement yet.

[BUG ?]UE4 4.10.4 "Infinite loop detected" in timeline ??

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [BUG ?]UE4 4.10.4 "Infinite loop detected" in timeline ??

    Hi ,

    sorry if i seem quite irritated .. i am ! ^^

    Okay so basically i have a Character blueprint and 4 timeline in it to drive camera movement (one for axis left and right , one for backward and two as a switch for the user preferences ) i have this blueprint setup for almost a week and then suddenly (since yesterday evening ) i can't launch my BP in the editor .. UE give me this beautiful error : Error Infinite Loop detected in "MyCharacterAimOffset2" , asserted during Timeline_01 with the following Call Stack"

    [PS: here is the call stack :

    http://pastebin.com/uhYMuZCx ]

    So i've checked out if i do had some loop in here and .. taadaam !!! : absolutely nothing --'
    i've un-wired (is this word exist ? xD) them but still the same error , so i've deleted the timeline in question .. and now i get error in the next timeline .. so i delete the next timeline .. ect ect .. finally i make a duplicate of my BP (maybe it was a bad sector in my HDD ) but still the same problem .. i've rewrited all my code .. still the same error ..



    For infos : yesterday the error appear , but if i restart the engine it works again .. (why ? idk --')
    today even if i restart i get the error ..

    i'm tired of this , i want to throw my computer through the f**ing window .. (but it's way too expensive for me to do that .. snif xD)

    So please , tell me that there is a solution ^^ pleeeeeaaase !!

    i know i've maybe not gived enough infos but if you need , screenshot , checkfiles , error message ect feel free to ask and i'll post it

    Thank you and have a nice day !

    Elvira.

    [PS : sorry for my english , i'm french]

    [EDIT] : i've deleted all the timeline in my BP , just to see what append .. now i have an "infinite loop blah blah blah " in .. be ready ... "input action jump " ... yep .. i know .. i feel very bad too :/

    [EDIT 2] : Alright , for poeple who are in kind of a same situation ; even if you think it's gonna be alien language : read the callstack .. seriously .. do it ! i've seen the name of a custom event all over the place .. i've tough myself that maybe this event was the cause of my problem .. and yes it was !! so read the callstack , maybe it gonna help you find a way to solve your issue
    Last edited by King_elvira; 04-16-2016, 08:34 AM. Reason: MaJ

    #2
    I'm having this exact same issue but in 4.14.0
    The file has always worked fine in 4.14.0 but suddenly is reporting infinite loop in my timelines. even when I disconnect them from ALL other nodes. Deleting the timeline just marks another timeline as "infinite loop"

    This is the same file that was playing just fine a few hours ago, the only thing that happened between then and now is that I put the computer to sleep for a few hours, then opened the file back up when I got back.

    [EDIT]Sorry I didn't mean to necro a thread, I failed to check the date of the first post and thought this was recent :/
    Last edited by Aumaan Anubis; 01-05-2017, 09:00 PM.

    Comment


      #3
      Originally posted by Aumaan Anubis View Post
      [EDIT]Sorry I didn't mean to necro a thread, I failed to check the date of the first post and thought this was recent :/
      I'm getting the same issue with 4.15, it's still a relevant issue!

      Comment


        #4
        I've been having this issue as well actually. None of them are set to autostart. I've tried disconnecting timelines and the error will just move to another timeline. This project doesn't even have that many and they are all "safe" from infinite looping; with how I've implemented them. I've also had the error pop up on timelines that are completely disconnected and not set to autostart.

        EDIT: Actually, scratch that. I found an infinite loop under a really extreme circumstance. However, it had nothing to do with any timelines at all.
        Last edited by IronicParadox; 03-19-2017, 05:57 PM.

        Comment

        Working...
        X