Announcement

Collapse
No announcement yet.

Turning off physics simulation on character blueprint

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Turning off physics simulation on character blueprint

    Hey guys,

    How can I turn off the physics simulation off on a character blueprint?

    I have my character blueprint with the ability to run and jump, but I also want them to be able to grab onto objects that are in the air. To do this I have used the attach actor to actor, which snaps the location but doesn't seem to actually 'attach' the two objects together. My plan is to disable the physics simulation on the character whilst it is 'grabbing', then turn it back on when it lets go. Is this the best way to do it?

    #2
    you can use something like physics interaction. When you access the character nods, you will find loads of useful stuff

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	50.6 KB
ID:	1051923
    Python for Unreal Engine Editor Tools Scripting

    Check my games & tutorials !

    Comment


      #3
      Thanks for the post!

      You made me realise I was referencing something else. I was using 'Get Movement Component' instead of 'Get Character Movement' - and you're right there are a load more options in there.

      In the end I went with the following:
      Click image for larger version

Name:	blueprint.png
Views:	1
Size:	17.6 KB
ID:	1051934

      Comment


        #4
        glad it works
        Python for Unreal Engine Editor Tools Scripting

        Check my games & tutorials !

        Comment

        Working...
        X