Announcement

Collapse
No announcement yet.

[Networking] Replicated Variable neglected in Anim Bluprint?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by PenguinTD View Post
    if they can rotate the entire character, what make you think a state means a enum or boolean? you can always fetch animation bp's owner(pawn or character) that have some vector/rotator to represent facing dir/rotation relative to body.
    well, that's what I'm doing. I have a variable of type transform that represents the head rotation/location. I first tried to replicate it in the anim blueprint, not in the character blueprint, which didn't work.
    I thought you were talking about using blends to e.g. blend a "look right" anim into a "look straight forward" anim. I guess I just didn't understand what you wanted to say in your first post, sorry

    Leave a comment:


  • replied
    if they can rotate the entire character, what make you think a state means a enum or boolean? you can always fetch animation bp's owner(pawn or character) that have some vector/rotator to represent facing dir/rotation relative to body.

    Leave a comment:


  • replied
    Originally posted by W1930U7 View Post
    I had a similar problem trying to get my Aim Offset animation to replicate.
    Here's an explanation of how I fixed that which might help you out:
    https://answers.unrealengine.com/que...plicating.html

    Thanks, that helped me to solve the issue.

    Basically, I had two errors:
    - The variable did not get replicated properly. I put it into the character blueprint, away from the anim blueprint. Changed some replication stuff, too.
    - I was also updating the wrong mesh (took me a while to figure it out...)

    Now it works, thank you!


    Originally posted by W1930U7 View Post
    you should try avoid replicate anything about actual animation. instead, make anything you want to do as state changes, and use states to drive your animation.
    I don't think that will solve my actual problem. I'm trying to replicate the head movement of an oculus rift. The character's head has no animation, the rotation is taken directly from the OR input.

    Leave a comment:


  • replied
    you should try avoid replicate anything about actual animation. instead, make anything you want to do as state changes, and use states to drive your animation.

    Leave a comment:


  • replied
    I had a similar problem trying to get my Aim Offset animation to replicate.
    Here's an explanation of how I fixed that which might help you out:
    https://answers.unrealengine.com/que...plicating.html

    Leave a comment:


  • [Networking] Replicated Variable neglected in Anim Bluprint?

    Hi,

    my Problem: I want to be able to rotate certain bones (in this case: the head) of my character and replicate it on the network.

    I have a float variable ("TESTheadRotation") in the anim blueprint. This variable is used to transform the bone, to make the character look left or right.

    The variable is set to "replicated". The blueprint is working on the local game. I can rotate the head locally as expected.

    Though, the other client is not considering the variable value. No matter what I do, the bone rotation does not work.

    I did my best to make sure the variable is actually replicated. My debugging skills are not so great, but it does seem to me that the value is replicated properly. It seems like the anim blueprint "of the other character" does not make use of it.

    Can anybody give me a hint? The anim blueprint is pretty simple actually (see screenshot).

    Thanks,
    Ben

    Click image for larger version

Name:	screenshot.png
Views:	1
Size:	168.1 KB
ID:	1135867
Working...
X