Announcement

Collapse
No announcement yet.

Custom collision not detected by line trace?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom collision not detected by line trace?

    Hello,

    I created a prop for my game with a custom collision box around it in max like so: Click image for larger version

Name:	YOpn7pG.png
Views:	1
Size:	363.7 KB
ID:	1176540 I made sure to call the box UBX_{rendername} and in while importing I disabled "auto generate collision".

    When I open the asset in unreal it looks like this: Click image for larger version

Name:	Yiai3GG.png
Views:	1
Size:	860.1 KB
ID:	1176541 So clearly the collision mesh did import correctly and I enabled cusomized collision (not sure if I need this?)

    Then I created a blueprint using this mesh and set my collision presets like I did with my other assets (which are just cube placeholders): Click image for larger version

Name:	ieiM9wu.png
Views:	1
Size:	29.0 KB
ID:	1176542

    Now when debugging it does not stop the trace when using "get hit result under cursor by channel" but when I set the collision to the "BlockAll" preset my character does walk against the custom collision mesh like it's a invisible wall (like it should be).

    Am I doing something wrong? Or is this an engine "bug"?

    Thanks in advance!

    PS: Running UE 4.10.4
    Last edited by Jannes D.; 03-18-2016, 04:46 PM.

    #2
    Still having this issue. Anyone?

    Comment


      #3
      Does it block the trace when you set it to Block All, if so, why don 't you use block all?

      Comment


        #4
        Originally posted by Mosel3y View Post
        Does it block the trace when you set it to Block All, if so, why don 't you use block all?
        It does not block the trace on block all but it does block my character from walking against it, now the thing is my character is a very small invisible sphere with a camera attached to it which makes sure that my camera is always the same height from the terrain. There's probably better ways to do this but it works just the way I want it to.

        Comment


          #5
          There's no reason it shouldn't work, if you replace the mesh in your BP, with another mesh, does the trace work on that?

          Comment


            #6
            Originally posted by Mosel3y View Post
            There's no reason it shouldn't work, if you replace the mesh in your BP, with another mesh, does the trace work on that?
            It works with the standard cube mesh, because the trace BP works. It's a get pos under mouse trace, I don't know if that changes anything.

            Comment

            Working...
            X