Announcement

Collapse
No announcement yet.

Can anyone please check my blueprints for me ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    from pattym's example it seems that you have some sort of dependency involved, I run into this before where if you compile one BP, another BP got messed up when they use cast/class related functions.
    And if you then just save and restart, it will look exactly like this.(thus require compile blueprints and then compile this messed up ones after choosing/connect the class/node again.)

    This was my question on answer hub quite a while ago, but I think it sort of apply to your situation.
    https://answers.unrealengine.com/que...ile-error.html

    so yeah, this is rare if you handle your dependency well, but it will show up when you are in fast prototyping mode and doesn't think through carefully.

    Leave a comment:


  • replied
    I thought I'd take a look. First thing is that the all the BP's are a mess. Looks like a miss match of stuff I've seen through out the forums. I get compile error from the "MyHUD" and "MyController" so I'm not actually able to play the game. If you truely want some help I would advise you to go through each and every BP and clean them all up and commenting along the way. You may even end up fixing your issue.



    As I look through other BP's I find there's a compile error is most of them. Here's a screenshot with the most common issues I find in most BP's. I'm not sure if it just happens to be the version you uploaded but either way each BP is a mess of wires with no idea of what each bit is supposed to do. Remember to make functions & macros for bit that would be used multiple times.

    Click image for larger version

Name:	BPError01.png
Views:	1
Size:	73.2 KB
ID:	1051966

    Leave a comment:


  • replied
    Originally posted by Sahkan View Post
    Only need to put My_BluePrint folder in the content folder...
    I'v tried to isolate the problem, made new blank projects with it, tried some stuff, it's like something is bugged over there... The blueprint works, when i package the game it gives me errors while i try to run the packaged game :
    https://forums.unrealengine.com/show...-packaged-game

    But besides that, it works perfectly ( When i change something in the blueprint, i save, quit editor, re enter, and it gets compiled while re opening the editor. if i try to compile right away the editor will crash to desktop ).
    I tried downloading your Blueprints, I can't even open them.

    What version of the editor have you made them in?

    Leave a comment:


  • replied
    Only need to put My_BluePrint folder in the content folder...
    I'v tried to isolate the problem, made new blank projects with it, tried some stuff, it's like something is bugged over there... The blueprint works, when i package the game it gives me errors while i try to run the packaged game :
    https://forums.unrealengine.com/show...-packaged-game

    But besides that, it works perfectly ( When i change something in the blueprint, i save, quit editor, re enter, and it gets compiled while re opening the editor. if i try to compile right away the editor will crash to desktop ).

    Leave a comment:


  • replied
    You would have a better luck if you tell us what errors you are getting and post screenshots of your BP's.

    Leave a comment:


  • replied
    You will be hard stretched to get people to download, install and review each and every node of your work, There must be errors or warnings along the way that your missing/ignoring or do they compile perfectly?
    Why don't you try putting them in a new project and testing that, also if your using Event Tick a lot then its going to be process heavy, Perhaps posting pictures of a set piece of code will help give us an idea,

    I personally don't have the time to download install and check your Blueprints, but maybe Epic will

    Leave a comment:


  • started a topic Can anyone please check my blueprints for me ?

    Can anyone please check my blueprints for me ?

    They are very slow and cause the game to crush often, unable to package the game without errors, while running frontend automatic check on the blueprints it just hang .
    https://drive.google.com/file/d/0B9t...it?usp=sharing

    I really need theme functioning like, yesterday please anyone...
    Last edited by Sahkan; 06-08-2014, 02:28 PM.
Working...
X