Announcement

Collapse
No announcement yet.

Lost control of third person chaacter, mouse doesn't work, errors in 3rd person BP >>

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Lost control of third person chaacter, mouse doesn't work, errors in 3rd person BP >>

    Click image for larger version

Name:	Untitled-1.jpg
Views:	1
Size:	475.1 KB
ID:	1172461

    Click image for larger version

Name:	Errors.jpg
Views:	1
Size:	79.7 KB
ID:	1172464

    Hi everyone,

    Lost control of my "play mode in selected viewer" inside the U4 editor.
    Screen grab above.
    Errors on most of the player input nodes.
    I can go in and out of the play mode but I cant do anything with the character or pan or tilt around in the viewer.

    What lead up to this issue:

    1. I had to do system restore 3 times to deal with a wifi driver issue.
    that issue fixed.
    2. I had to re-install upgrade from 10.2 to 10.3 twice in the launcher.

    Should mention another U4 game project I have works 100%. No issues.
    So U4 seemed to have survived the bump in the road. :-)
    Just this one project file is broken for some reason.

    Is there a way to "reset" the third person character BP?
    Typo in header sorry, working fast here :-)

    Next question is if there is no fix for this I can just rebuild the map again.
    I just created a new test 3rd person project and that works fine.
    I just need to save one thing off this broken map and that is the Matinee with
    movement track I created.
    Is there a way I can export that (not a rendered movie the actual Matinee)
    and set that up with a new camera on a new map?

    Thank you!!
    Last edited by Etienne Andlau; 02-18-2016, 09:54 PM.

    #2
    Are you sure the Input events exist?

    Have you tried refreshing the Input Event Nodes?
    Im an Moderator on UnrealSlackers Discord! Which is a Community driven group of likeminded people here to discuss UE4! Join UnrealSlackers on Discord!

    Comment


      #3
      Originally posted by DevilsD View Post
      Are you sure the Input events exist?

      Have you tried refreshing the Input Event Nodes?
      Hi thanks. Silly question sorry but how do you refresh them? I tried to put new ones on the graph but they dont show in the menu that pops up when I right mouse click.

      If I ctrl+W then I get an error

      Comment


        #4
        Click image for larger version

Name:	attachment.jpg
Views:	2
Size:	179.2 KB
ID:	1100825

        Should mention I had this setup in the level BP before problem began.
        This is not a game its an animated logo I am rendering out of Matinee.
        This was set up so the Matinee camera kicks in if you hit play and then renders out movie.
        That all worked fine.
        Then I wanted to just "play" the level for some silly reason so I disconnected the eventbeginplay node and re - compiled
        the level BP.
        That is when viewer froze up.
        Then I deleted all the nodes from the level BP but the problem didn't go away.
        So dont know if I broke something ... probably :-)

        Comment


          #5
          Click image for larger version

Name:	Untitled-1.jpg
Views:	1
Size:	146.6 KB
ID:	1100827

          I replaced these nodes and now I can pan around and look up and down in the viewer in play mode.
          So ... looks like my controller input nodes are all corrupted ... I just have to replace them.

          Comment


            #6
            O.k. YAY I figured out what is going on here.
            With all the system restoring fun I had settings on my level got all screwed up.
            I did notice that the colors of my folders changed back to grey.
            That was a clue :-)
            So my input axis mappings under project settings all got wiped.
            I am setting those up again and now my character can run forward, backward and jump.
            So I think this problem is solved ... HEH !!!

            Here is a link to the documentation for those of you who are new to Unreal and dont know what
            I am talking about here:

            https://docs.unrealengine.com/latest.../axismappings_

            Click image for larger version

Name:	Solved.jpg
Views:	1
Size:	201.9 KB
ID:	1100830
            Last edited by Etienne Andlau; 02-19-2016, 04:57 AM.

            Comment

            Working...
            X