Announcement

Collapse
No announcement yet.

Multiplayer Lobby Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Multiplayer Lobby Problems

    Hey everyone,
    I've been pounding my head against the keyboard for a few hours now...
    I've been trying to merge a sample project I found on the forums a long time back (meant for 4.7) from HERE
    Much thanks for the project!

    I've run into a bit of a snag though.. I am getting errors for the current state, and I don't know if that's handled differently in 4.10 (which I am using now)
    I attached 2 pics to show where I believe the errors are stemming from...

    any ideas on what to do to fix it?

    Click image for larger version

Name:	Gwii8u2.jpg
Views:	1
Size:	409.1 KB
ID:	1171779
    Click image for larger version

Name:	lLyiFHR.jpg
Views:	1
Size:	46.3 KB
ID:	1171778

    #2
    double post.

    Comment


      #3
      Current State is of type Byte, but I guess it has to be type Enum (the enumerator you created).

      So when you assign the variable type write the name of your enumerator.

      You probably mistaken as they both have green icons.

      Comment


        #4
        You shouldn't use that any more, i mean by means do use it if you want but the multiplayer blueprint session nodes were released and updated since that project. Check out the multiplayer shootout epic demo in the learn tab.
        Youtube
        Machine Learning C++ Plugin
        Lindenmayer System C++ Plugin

        Comment


          #5
          As a beginner it's still better he builds the stuff himself I think rather than digging code and blueprints.

          Comment


            #6
            current state is the enum, you need to make sure your input 'In State' is set to a enum as well.. not a byte.
            Acclivity Game Studios. Making a BP FPS, Tutorial Series on Blog : On Unreal Wiki : Twitch

            Comment


              #7
              Originally posted by Aquazi View Post
              As a beginner it's still better he builds the stuff himself I think rather than digging code and blueprints.
              I'm by no means good at coding, and for me to write/build this system from scratch is not something I want to even attempt... so I'd rather dig through code and edit.
              Besides, that's why people put things on the Marketplace, there are some of us who would like to have it ready made and drop it in. Exactly as I have done with a free sample.

              Originally posted by arbopa View Post
              current state is the enum, you need to make sure your input 'In State' is set to a enum as well.. not a byte.
              Bingo! in fact, both inputs and outputs had switched to Byte... So I had to change them both!
              And on top of it, in the Current State Switch, the "Switch on State" became corrupt and was calling (bad enum) and not populating ANY of the info in the Event Graph!
              I had to go in and manually update each one from the drop down box.. But I'm almost done that now. I'm just happy it compiles successfully

              Thanks arbopa!
              ******* Edit*******
              After updating all Leave_Current_State "desired state" drop downs, it still seems when I launch the menu, I am only getting a black screen.. any ideas? I'll be working on it in the mean time.
              Last edited by Demrok; 02-09-2016, 06:13 PM.

              Comment

              Working...
              X