Announcement

Collapse
No announcement yet.

"Set Input Mode Game and UI" node not working for inventory

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Set Input Mode Game and UI" node not working for inventory

    Hey, I'm trying to create a working inventory system for my game, because I'm not very good at scripting I am using this video tutorial to help me: https://www.youtube.com/watch?v=xJKZQrFoPWc I've replicated everything to part 7 and here is where I am a bit stuck, I don't know if I'm doing it wrong or something changed in the new version, but it seems to not be working how I would expect it to work. If you watch the video, on there every thing works fine.

    Opening inventory works, but when I'm trying to close it, it won't work, but when I click the left mouse button anywhere on the inventory and I press (tab) to close it, it will work. That's the **first problem**.

    **Second problem**, after closing the inventory the camera movement won't work like it worked before I opened it, if I want to move the camera, I am forced to hold the left/ right mouse button.

    That isn't working like in the video tutorial. He even shows you how to fix this and yes I've done the same thing that he did, added the "**Set Input Mode Game and UI**" and "**Set Focus to Game Viewport**" nodes. The way that it should work is when you press (tab) it will open, and when you press (tab) again it will close, without clicking on the inventory, and after closing it, the camera movement should work like it did before opening it.

    How do I fix this? please if anyone knows how to fix something like this, please... reply to this, thanks

    Oh yeah and this is a video, that I've created, to show you it:

    https://www.youtube.com/watch?v=BkvL...ature=youtu.be

    Click image for larger version

Name:	cus.jpg
Views:	1
Size:	418.4 KB
ID:	1170419
Working...
X