Announcement

Collapse
No announcement yet.

Event Use Action

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Event Use Action

    I'm looking at the inventory ui with umg tutorial to add an inventory into my game. Ive got the graphical side all working and Ingame.

    I have some computer components I made that I want to be able to pickup in game. So I made the model, textured it. Imported it and set it all up. I'm now working on the blueprint for it and I'm copying the code for canpickup blueprint just to get me started because I am very new at this. And literally understand nothing. Alls working fine so far except when I get to one part for when the item is used, theres an EVENT USE ACTION command that comes from the ACTIONINTERFACE which is a interface blueprint that I made earlier.

    The example map has the EVENTUSEACTION in the event graph, in the canpickup blueprint. But my ElectronicPartsPickup Blueprint does not.
    Any idea how I link it to the object blueprint so I can call it.

    Thanks

    Just realised I cant call the EVENUSEACTION or the EVENTDROPACTION - So I must have to link it somehow but cant figure it out
    Last edited by viggerz; 01-04-2016, 03:37 PM.

    #2
    Also my inventory slot is not updating with the 32x32 texture I have for it. Any ideas why would be a great help.

    Click image for larger version

Name:	1.png
Views:	1
Size:	475.8 KB
ID:	1097967
    Click image for larger version

Name:	2.png
Views:	1
Size:	325.7 KB
ID:	1097968
    Click image for larger version

Name:	3.png
Views:	1
Size:	220.6 KB
ID:	1097969
    Click image for larger version

Name:	4.png
Views:	1
Size:	229.6 KB
ID:	1097970

    Comment


      #3
      strangest thing, I woke up this morning and the inventory 2d image now works? Pixies must of fixed it over night.

      I still cant get the event to come up tho.

      Comment

      Working...
      X