Announcement

Collapse
No announcement yet.

Problem with AttachActorToComponent

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with AttachActorToComponent

    Hi,

    As soon i attach an actor to a socket with AttachActorToComponent node, the third player controller is messed up (going straight goes to the left for example)

    For example in the level blueprint of the thirdPerson template project:

    Click image for larger version

Name:	LevelBlueprint.jpg
Views:	1
Size:	99.0 KB
ID:	1169600

    Do someone have an explanation about that ?


    Edit: I get the same problems with a Child Actor Component, but not with a StaticMesh Component
    Last edited by Daes; 01-03-2016, 05:04 PM.

    #2
    Could it be something collision or overlap related? Try disabling collision for every component on your sword to make sure it is not the cause. If it is the cause, you may need to look into using collision channels.
    Ryan Brucks
    Principal Technical Artist, Epic Games

    Comment


      #3
      Could also be an issue with the sword actors root component(usually collision) Transform, whether it is Static vs Movable. EG. attach a Static actor blueprint to a Movable character, weird things start to happen IIRC
      Last edited by DEDRICK; 01-04-2016, 07:19 PM.

      Comment


        #4
        Thanks for pointing me on collision.
        I tried with a starter content blueprint (blueprint_WallSconce) and i get the same results.
        So I change the blueprint StaticMesh Collision presets to None and problems disappear.

        But it is strange that doing the same with the staticMesh Component instead of Child actor Component (with same static mesh) and letting it with the collision default presets (which are the same), is not causing any problems.

        Comment

        Working...
        X