Announcement

Collapse
No announcement yet.

This is driving me insane, and no one wants to help. True First Person Clipping bug.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    This is driving me insane, and no one wants to help. True First Person Clipping bug.

    Camera Boom does nothing.

    Moving the camera does nothing.

    Help.

    This is how it looks:
    Click image for larger version

Name:	72349-god+damnit.png
Views:	1
Size:	732.3 KB
ID:	1169428

    I am seriously considering re-subscribing to CRYENGINE.

    #2
    I'm about to spend $10 to buy something way harder to learn.... come the **** on.

    Comment


      #3
      What is the issue here? There is no context or reference to what should be happening as opposed to what is happening.

      Are you able to show us a video or explain in detail what is happening. This is just a screenshot for all we know its intended design since nothing looks odd to me.
      Im an Moderator on UnrealSlackers Discord! Which is a Community driven group of likeminded people here to discuss UE4! Join UnrealSlackers on Discord!

      Comment


        #4
        Basically when the player is facing against a wall and moving, they can see through. The game is meant to be a fast FPS, and clipping like that makes the game look bad. There was originally geometry there.

        Comment


          #5
          This is what it looked like normally.
          Click image for larger version

Name:	thisiswhatibroke.png
Views:	1
Size:	792.1 KB
ID:	1097771

          Comment


            #6
            You have 2 options you can try.

            1. Increase the size of the Players Collision to encompass all areas on the Character that the camera may move to so that it doesnt intersect with Geometry.

            2. Change the Near Clipping Plane for the Viewport which can be found in Project Settings > General Settings > Settings > Near Clip Plane

            I recommend trying the first option, changing the near clip plane affects the Viewport and subsequently all Cameras, it requires an Editor Restart to take effect. As far as im aware it cannot be modified at runtime on the fly either.

            To me it just seems that your collision radius is not big enough to avoid situations like this.
            Last edited by DevilsD; 12-30-2015, 11:20 PM.
            Im an Moderator on UnrealSlackers Discord! Which is a Community driven group of likeminded people here to discuss UE4! Join UnrealSlackers on Discord!

            Comment


              #7
              I actually tried number 1, made the player feel floaty and bloated.

              Comment


                #8
                Originally posted by NorseHorse1492 View Post
                I actually tried number 1, made the player feel floaty and bloated.
                Reducing the value of the Near Clip Plane will allow Geometry to draw closer to the Camera.
                Im an Moderator on UnrealSlackers Discord! Which is a Community driven group of likeminded people here to discuss UE4! Join UnrealSlackers on Discord!

                Comment


                  #9
                  From my point of view, harden yourself.
                  This is a really small problem and you show a template without edited or own stuff and talking about giving up?
                  You not even started
                  First thing what helped me using the mighty UE, was to know, how to find answers first.
                  You do not need to know anything, you only have to find the right answers.
                  https://www.google.de/?gws_rd=ssl#q=ue4+fps+clipping
                  My small game on IndieDB ****** Beams on Twitter ****** Beams on Steam ****** VideoStuff ****** PictureStuff
                  UE brings Math back into my life or i am not sure.

                  Comment

                  Working...
                  X