Announcement

Collapse
No announcement yet.

Functions- Direct Blueprint Communication- Doesn't work.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    You can submit an answerhub thread for better issue tracking. It seemed to me like you were on the path the solving the problem but if you still need help by all means, an answerhub thread cant hurt.

    Leave a comment:


  • replied
    Does I have to post this like a bug on answerhub forum?

    Leave a comment:


  • replied
    Originally posted by RyanB View Post
    Hey,

    You did not answer the questions I brought up yet such as how are you defining the reference of "Valor" to be an actual blueprint. It seems to me you are just calling it on an empty variable with no reference to an actual blueprint actor.
    Sorry, I didn't reply because and I was not sure I was doing. You are right, it was a empty variable, and I have deleted all and I have started a new code. Now, I think I am on the right way. (I am just testing with print string or toggle visibility).

    Leave a comment:


  • replied
    Ok, I have read this: https://docs.unrealengine.com/latest...mms/index.html and it works with the Character and the Blueprint object, but when I try it with a Widget and the Blueprint object, doesn't. Maybe a bug?

    1. First step. Public variable on Widget and the fuction.
    Click image for larger version

Name:	29-12-2015 19.12.43 1.jpg
Views:	1
Size:	95.6 KB
ID:	1097721

    2.Second step. Bug? I tried to get the refence for the Widget and I can't. I select the BP_Box but it keeps: "none". Then I try again and it appears the second image:
    Click image for larger version

Name:	29-12-2015 19.12.21 3.jpg
Views:	1
Size:	34.6 KB
ID:	1097722Click image for larger version

Name:	29-12-2015 19.12.1 4.jpg
Views:	1
Size:	12.7 KB
ID:	1097723

    3. Third step.
    Click image for larger version

Name:	29-12-2015 19.12.49 2.jpg
Views:	1
Size:	102.5 KB
ID:	1097724

    Leave a comment:


  • replied
    Hey,

    You did not answer the questions I brought up yet such as how are you defining the reference of "Valor" to be an actual blueprint. It seems to me you are just calling it on an empty variable with no reference to an actual blueprint actor.

    Leave a comment:


  • replied
    Any idea to resolve this?

    Leave a comment:


  • replied
    Sorry, I don't know how to do this, but I can translate it. (How can switch the editor to english for post images here?) "Estoy= to stay", "Valor=value", "Estancia=room". I gave a number for each room like this image. This a blueprint object, a floor:
    Click image for larger version

Name:	28-12-2015 20.12.16 1.jpg
Views:	1
Size:	41.5 KB
ID:	1097668
    I have a main menu with a button called "Acabados". When I press it, it should run to the function stay ("estoy", which is created on main menu widget), and print a string, the number of the value "estancia".
    Last edited by pnunez; 12-28-2015, 03:26 PM.

    Leave a comment:


  • replied
    It appears that you have made "Valor" an input to the function "Estoy" without actually connecting your "Valor" variable to the function call (the node connected to OnPressed). Also, where are you assigning the variable an actual reference?

    You are right that doing things this way is far cleaner than using "get all actors of class". Get all is ok for light use or testing purposes but you definitely don't want to be doing it all the time.

    Leave a comment:


  • replied
    Can you switch unreal editor to English? I guessed that one node is print. But that "Estoy" may be few different things.

    Leave a comment:


  • Functions- Direct Blueprint Communication- Doesn't work.

    Hi! I am making a blueprint to conect a Widget with a Blueprint object. This is the situation: I have some collison boxes on the blueprint object, and from each one I have a diferrent value when the player is in it: integer variable. Then when I press a widget button, I want to print the differents values, but It doesn't wrong. I did it before with "Get All Actors of Class node" but I have read that is not a good solution. Thank you.
    Click image for larger version

Name:	28-12-2015 16.12.13 1.jpg
Views:	1
Size:	84.3 KB
ID:	1169292Click image for larger version

Name:	28-12-2015 16.12.23 2.jpg
Views:	1
Size:	32.9 KB
ID:	1169293
Working...
X