Announcement

Collapse
No announcement yet.

Destroy Pawn = Pawn goes to his Physics Assets and fall to Ground

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Destroy Pawn = Pawn goes to his Physics Assets and fall to Ground

    Hello,

    with this BP:
    Click image for larger version

Name:	DestroyPawn.png
Views:	1
Size:	363.3 KB
ID:	1169268

    did i try the following:
    If my Character shot to this Pawn, then the Pawn did not shows a Destroy-Animation - my idea is that the Pawn shoud goes to his PhysicsAssets and fall to the Ground (= Dead).

    But with this Setting in the picture, it did not work. Have someone a idea what is false?

    Kind regards,
    halobungie
    Last edited by halobungie; 12-27-2015, 10:56 AM.

    #2
    You must set physics simulation on skeleton to 1.0; it is proly at 0.0 that's why you can't see any ragdoll simulation.
    | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

    Comment


      #3
      Hello Bruno Xavier,
      i can't find this Setting - where exactly can i find this? Please show me a picture from this Setting, if it's possible.
      Kind regards,
      halobungie

      Comment


        #4
        I'm away from my workstation today; there must be something about this in docs or tutorials.
        | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

        Comment


          #5
          Hello Bruno Xavier,
          i can wait - you make me happy when you can send me the Screenshot when you are at home.
          kind regards,
          halobungie

          Comment


            #6
            That node you use already does the blend weight thing I was talking about;
            So do this and see if works for you then:


            Last edited by BrUnO XaVIeR; 12-27-2015, 03:49 PM.
            | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

            Comment


              #7
              Hello Bruno,
              i have changed the Setting like you has said, but it don't work:
              Click image for larger version

Name:	Dead_from_Pawn.png
Views:	1
Size:	390.3 KB
ID:	1097632
              Is something other false in the Setting?
              Kind regards,
              halobungie

              Comment


                #8
                In the "In Collision Profile Name" field where it says 'None', type "Ragdoll". Can't be none.
                | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

                Comment


                  #9
                  Hello Bruno,
                  i have changed this - but without succes.
                  Do you have another idea?
                  Kind regards,
                  halobungie

                  Comment


                    #10
                    No idea; check your collision settings for Ragdolls and floor meshes. They must block each other or your character will keep falling through the ground.
                    | Savior | USQLite | FSM | Object Pool | Sound Occlusion | Property Transfer | Magic Nodes | MORE |

                    Comment


                      #11
                      Hello,
                      is there any good example out there with this Setting?
                      For to see how it works...
                      Kind regards,
                      halobungie

                      Comment

                      Working...
                      X