Announcement

Collapse
No announcement yet.

Scene loading time with blueprints

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Scene loading time with blueprints

    Hi everyone,

    I am new to UE4 and i am trying to get familiar with engine. I have made a very simple tapping game with paper 2d, logic is working well, but there is something that i cannot understand. The scene loading time. Game scene is VERY simple. It is just a static background image sprite, 3 randomly spawned sprites, some text widgets for UI and hidden view with text and buttons for restart screen. The second scene is main menu, no bg, 3 buttons and hidden view with checkbox and slider (for sound settings).
    Every of the scenes mentioned above takes ages to load (as for content they have inside). I would think it should take like <1sec to load, but in reality it is like 6-7sec. When i try to restart the game scene it takes less, like 4sec, but still it is a big number for me. Restart is done with console command restart level if someone asks.

    #2
    It is impossible to help without seeing the way you prepared things.

    It can be helpful to get your project zipped and put in dropbox incase people might want to download to check what's going on.

    Also try to remove things one at a time, or rather add them one at a time to check if loading is going okay or not. So you will be able to understand what's taking things so long to appear.
    Fighting Game Template: PROJECT: Unreal Fighter 2D

    Comment


      #3
      Do you have this problem in the Editor or in the packaged project? Is your HDD messed up (i think the correct word in english for this is "fragmented") or is your PC slow at all?
      If the Editor needs 6s, that´s a very good time, but in the packaged project this is a problem? Have you tried to optimize it? Maybe you should look at the Taskmanager while opening the file.

      Comment


        #4
        Originally posted by Fragment7 View Post
        Do you have this problem in the Editor or in the packaged project? Is your HDD messed up (i think the correct word in english for this is "fragmented") or is your PC slow at all?
        If the Editor needs 6s, that´s a very good time, but in the packaged project this is a problem? Have you tried to optimize it? Maybe you should look at the Taskmanager while opening the file.
        6s is from device with development stand alone build. This time is the same in pie. I am attaching project zip, so you can take a look at it.
        project zip link

        Comment

        Working...
        X