Announcement

Collapse
No announcement yet.

Problem With Time Attack Racer Tutorial

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem With Time Attack Racer Tutorial

    Click image for larger version

Name:	HelpMe.png
Views:	1
Size:	216.2 KB
ID:	1162261

    When I try attach "Array Element" to the "Target" it says that "Actor refeference is not compatible with CheckPointReference. But I have done everything exactly in the same way which is done in tutorial. By the way "CheckPointCleared" is an "Event Dispatcher" which is in another blueprint. Actually I have read to learn what it is but I don't understand exactly. If "CheckPointCleared" were a function which is in another blueprint, should I cast that blueprint to acces it's function right? I mean since it is an "Event Dispatcher" I dont have to get a reference for that blueprint? I am a bit confused guys. Please help me.

    English is not my mother language so sorry for mistakes.

    Edit: https://wiki.unrealengine.com/Videos...eo=trdAsxgSGJY

    This is the tutorial link and that guy is making this at 10.45-10.50.
    Last edited by catacombrocks89; 10-02-2015, 03:25 PM.

    #2
    The Array Variable is of type Actor, not CheckPoint. To be able to bind to it, you need to either change the variable type of your Array or cast the Array Element to the CheckPoint type.
    Im an Moderator on UnrealSlackers Discord! Which is a Community driven group of likeminded people here to discuss UE4! Join UnrealSlackers on Discord!

    Comment


      #3
      Click image for larger version

Name:	ALL.png
Views:	1
Size:	647.6 KB
ID:	1106494
      Click image for larger version

Name:	pART.png
Views:	1
Size:	918.4 KB
ID:	1106495

      I have a problem where I keep getting the following error:
      Blueprint runtime error: Accessed none trying to read property CallFunc_Array_Get_Item2 from function "Lap Check" from node Set Respawnlocation in lapcheck in object tracker

      Everything seems in order following the below tutorial.
      https://www.youtube.com/watch?v=j-c37wG-Za8
      Could you tell me what I am doing wrong

      Comment

      Working...
      X