Announcement

Collapse
No announcement yet.

Set Simulate Physics for Character

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Set Simulate Physics for Character

    I am trying to make it so when a variable, Health, reaches 0 the player will go ragdoll. I tried to use the Set Simulate Physics node but it wasn't working. I noticed that the checkbox for this options under the details panel was grayed out. WHY?

    #2
    Have you got a Physics Asset for the Character? If not you need to create one. Unreal creates its own on import of the Skeletal Mesh if the option is selected. You also need to disable the Character Capsule component on death.

    Show us your death event if you can?

    Comment


      #3
      I am using the default Side Scroller Character by the way.

      Click image for larger version

Name:	codess.png
Views:	1
Size:	367.8 KB
ID:	1088557

      Comment


        #4
        Because I'm not on my development machine Ill give you a link to what I mean. In the link below. Look at the picture right at the bottom.

        https://forums.unrealengine.com/show...l-on-collision

        Comment


          #5
          Yeah the PHAT panel is a separate 1 that you need to setup. The default character may not have 1 at all or if it's been given 1 by default then it wont work very well because there will be a lot of overlaps. Rama's plugin has a simple way of triggering ragdoll on and off so I would suggest checking that out.

          Comment

          Working...
          X