Announcement

Collapse
No announcement yet.

Placing boxes via Blueprint does not work properly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Check "Manual Attachment" to be true on the Add static mesh component node. If you read the tooltips on 'Add static mesh component' it will sort of explain things. The problem is it's using the first cube as the root component and setting the transforms of the subsequent cubes relative to that.
    Last edited by -Ross; 09-25-2015, 08:07 AM.

    Leave a comment:


  • Placing boxes via Blueprint does not work properly

    I'm very new to UE4 and using version 4.9.0 i encountered a Problem with the easy task of adding boxes using the level blueprint.
    The boxes are not placed in the proper positions wile the output log states the right ones.
    So that might be a problem with my use of the relative Transform of the AddStaticMeshComponent, but actually i cant figure out how to fix it.

    The result:
    Click image for larger version

Name:	perspective.png
Views:	1
Size:	151.9 KB
ID:	1161828

    The Script:
    Click image for larger version

Name:	2015-09-25 11_44_28-Untitled_ - Level Blueprint Editor.png
Views:	1
Size:	154.2 KB
ID:	1161827

    Output log:
    LogWorld: Bringing up level for play took: 0.006794
    LogBlueprintUserMessages: [Untitled_C_1] X=400.000 Y=0.000 Z=150.000
    LogBlueprintUserMessages: [Untitled_C_1] X=400.000 Y=100.000 Z=150.000
    LogBlueprintUserMessages: [Untitled_C_1] X=400.000 Y=200.000 Z=150.000
    LogBlueprintUserMessages: [Untitled_C_1] X=400.000 Y=300.000 Z=150.000
Working...
X