Announcement

Collapse
No announcement yet.

widget GetPosition node returns 0,0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    i need screen position, x and y

    Leave a comment:


  • replied
    If you want the index: http://puu.sh/mZVJZ/1c7423c1fa.png

    For visual reference (wrap box with 2 buttons): http://puu.sh/mZVMn/5812b60e31.png

    Leave a comment:


  • replied
    same problem here. cannot get wrap box slot position. did u managed to get it working by any chance ?

    thx

    Leave a comment:


  • replied
    Looks like problem is with Slot as Canvas Slot node. If I connect my child widget to it I get null on the out pin but If I connect widget->GetParent to it, cast is succesfull. Still this gets me only parent position which is same for all child widgets

    Leave a comment:


  • replied
    Don't think so. There are multiple widgets added to this wrap box and every one returns 0,0 while visually they are in different positions

    alright, since it shouldn't return 0,0 then probably it's a bug in my code
    Last edited by laggyluk; 09-17-2015, 03:39 PM.

    Leave a comment:


  • replied
    Just a thought, is it possible that it is returning the position as 0,0 due to it being 0,0 relative to it's parent container?

    Leave a comment:


  • started a topic widget GetPosition node returns 0,0

    widget GetPosition node returns 0,0

    Widgets added to wrap box container return 0,0 when using 'Slot as Canvas Slot'->GetPosition node. Bug or feature?
Working...
X