Announcement

Collapse
No announcement yet.

My E Button doesn't work in my self created actor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    thanks solved thanks man

    Leave a comment:


  • replied
    Everything placed into the Scene is at least an Actor! That's why i said Actor.
    I mean the object you want to use. The generator.

    Leave a comment:


  • replied
    but my character is the actor xD or you mean the object?
    I'm confused ahahha

    Leave a comment:


  • replied
    Sometimes i feel like you are trolling me xD

    I said: "Add a Collision to the Actor you want to use." and not to the Character.

    Also the "GetPlayerController" needs to be in the "PlayerController" pin and the Target needs
    to be empty or self.

    Leave a comment:


  • replied
    i created the two blueprints

    And this is the sphere of collision...

    Wht stil doesn't works? what i ve wronged?

    Leave a comment:


  • replied
    Originally posted by Siengried View Post
    i don't know how to add the collision...all the on begin overlap i don't know
    Then please search the internet for it. This is a basic thing. I can't post you pictures etc every time. Youtube also
    got tutorials about collision and you may want to watch the basic tutorials of Epic Games Youtube Channel!

    https://www.youtube.com/user/UnrealD...tKit/playlists

    Leave a comment:


  • replied
    i don't know how to add the collision...all the on begin overlap i don't know

    Leave a comment:


  • replied
    Add a Collision to the Actor you want to use. Make sure it is big enough for the Character to step into.
    Add the OnBegin- and OnEndOverlap Event of it to the Event Graph. For OnBeginOverlap get your
    PlayerController and call "Enable Input". For the OnEndOverlap get your PlayerController and call "Disable Input".

    Leave a comment:


  • replied
    how i cann add input? The collision ecc?

    Leave a comment:


  • replied
    Like eXi is saying and to add to that:
    Input is by default only enabled for the player's controller, pawn and the level blueprint (in that order of processing). For others you need to call EnableInput. It will then receive input before the player controller.

    Leave a comment:


  • replied
    Do you have Input enabled for this Actor? Can you debug the Blueprint and look if the "E" press is actually called?
    Either by looking if the wires light up or by adding a print message.

    If the E Button is not working, you are missing the Enable input. You will want to add a collision to this Actor and
    OnBeginOverlap, you enable input and also OnEndOverlap you disable it again.

    Leave a comment:


  • started a topic My E Button doesn't work in my self created actor

    My E Button doesn't work in my self created actor

    Hi all...
    i have this blueprints...

    Now when i press e toward to my object the light and the audio doesn't works...why?
Working...
X