Announcement

Collapse
No announcement yet.

4.9 Has Broken my game!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.9 Has Broken my game!

    Hi,
    4.9 has broken my game but I need it package my game onto Android because 4.8 gives me errors.

    The game worked fine on 4.8

    I followed this tutorial to make an endless runner - https://www.youtube.com/watch?v=yS-y...uEPVC9PzQThNn1

    The messages I am getting are these:

    Error Cannot access 'BP_FloorTile_C_90'. It is pending kill. Property: 'K2Node_DynamicCast_AsBP_Floor_Tile' from node Get Attatch Transform in graph 'AddFloorTile' in blueprint RunGameMode

    Info Play in editor start time for /Game/ThirdPersonBP/Dale_Menu/UEDPIE_0_menu 0.533

    #2
    It looks like you are destroying the floortile and after destroying it you are trying to pull some data from the actor. You should always destroy an actor at the end of a function as opposed to in the middle of it.
    Adam Davis | Marketplace Support | Epic Games
    How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

    Comment


      #3
      Hi!

      In UE 4.9 in node Spawn Actor From Class appeared a new attribute "Collision Handling Override". You should set this attribute to Default. Open the RunGameMode blueprint and fix it.

      Click image for larger version

Name:	game01.PNG
Views:	1
Size:	137.2 KB
ID:	1083659

      Click image for larger version

Name:	game02.PNG
Views:	1
Size:	137.6 KB
ID:	1083660

      Comment


        #4
        Problem solved thank you!

        Comment


          #5
          4.9 is still in it's experimental stages, bugs and issues are to be expected, and you will likely run into problems if you are packaging with preview versions of the engine.
          Marketplace Assets

          Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
          Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
          Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

          Comment


            #6
            I have made them to default and againt nothings changing

            Comment


              #7
              I am also facing a similar problem. I am using version 4.11.2 and I have changed the collision thing to default but still not able to spawn the floor tile. Please help me out with this

              Comment


                #8
                I had the same problem and fixed it by changing the game mode from "RunGameMode" back to "ThirdPersonGameMode". Apparently, renaming it in the first place did not rename all references.

                Comment


                  #9
                  [MENTION=346153]DavePilot[/MENTION]'s answer fixed my problem, renaming the game mode broke something !

                  Comment

                  Working...
                  X