Announcement

Collapse
No announcement yet.

Real basic trigger query re sound keeps resetting problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Real basic trigger query re sound keeps resetting problem

    Hi there I am sorry to post such a noob question but I have been messing with this for ages and couldn't find any relevant posts.

    I want a sound to be triggered by a trigger volume in the level, that's fine I can do that, I can put in a 'do once' box to kill it after it plays once, again that's fine. The problem is the bloody sound keeps stopping when I exit the trigger volume, so it only plays part of what I want. I have the attenuation box set so the sound gets quieter the further you are away from it, but as I say it keeps shutting off completely.

    I have no doubt it is something basic I am not selecting, any feedback greatly appreciated

    Fal

    #2
    Maybe show us your blueprint? (:
    @CarstenZarbock - Follow me on Twitter, thank you

    Comment


      #3
      KrautPotato hi yes if it comes to that, I just checked in the engine and with the blueprint in the background everything is working fine however the audio stops playing completely when outside the attenuation range so when you re-enter the area you should start to hear the sound it is silent. I wanted the sound to keep playing regardless if there is anyone present, so you can wonder back a few minutes later and the remainder of the song is playing as expected.

      Its a bit of a conundrum like if a tree falls in the woods and no one is there, does it make a sound? lol

      edit- how I solved the problem originally was brute-forced it by setting the attenuation limit to the size of the full level, so you never wander outside it. This does not seem very eloquent though and upsets the range you can set the fade-out to.
      Last edited by Falan; 08-03-2015, 05:34 AM.

      Comment

      Working...
      X