Announcement

Collapse
No announcement yet.

Standalone play screws-up my camera afterward

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Standalone play screws-up my camera afterward

    Hello,

    I have a very simple scene where I control the camera inside a blueprint class.

    It works well in simulation mode.

    If I play it in standalone mode, it also works, but after that it does not work anymore in simulation mode

    I've been struggling with that for several days and I am stuck

    Would anyone have an idea ?

    Is that a bug ?


    Regards,


    Zoro321

    #2
    Here is my blueprint script.
    Attached Files

    Comment


      #3
      As I said, it works fine until I play it in "Standalone" mode.


      Then after that, if I play it under "simulation" again, the camera is not controled by my script anymore but by regular keyboard/mouse.

      Comment


        #4
        What camera are you passing in with your "Cam" variable?
        CTO Villusion Studios
        Grad Student in Interactive Design and Game Development, SCAD
        company site: http://www.villusionstudios.com/

        Comment


          #5
          I am passing it a reference to a CameraActor that I select in the persistent level.

          I add a camra object in my level and then I eference it in my CameraMover lueprint class.


          In fact, I found that even if I pt hat into my Level blueprint, I et the same behaviour.


          I fond a workaroun by pessig the "Launch" button instead of "Play". with the drawback to recompile my project a every trial.

          Comment


            #6
            Just try it:


            - Create a level blieprint as shown in the picture above.
            - Run it in simulation mode as much as you want (you will see it works fine).
            - Run it in standalone mode once.
            - Play it under simulation mode again: you will see it does not wor4k anymore.


            Is that a bug or a natural behaviour ? A setting to change ?

            Comment


              #7
              Hello,


              I just figuredit out
              \
              \
              When playing under simulation, I have to click the "Possess" button

              Comment

              Working...
              X