Announcement

Collapse
No announcement yet.

Material Not Doing Same Thing In Game As It Is In Blueprint Component Viewport.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Material Not Doing Same Thing In Game As It Is In Blueprint Component Viewport.

    My blueprint is not reproducing the effect in the game as it is when i do inside the blueprint it self.
    Here in the blueprint view port tab, i am increasing the radius of a sphere which is setting a material of a block based on location/radius of the sphere. And as you can see as i increase the radius, the material becomes visible on the block. However when i do this in game, it is just always not visible.

    Click image for larger version

Name:	c0bb645b8bf9c000c17a53e84da471fe.gif
Views:	1
Size:	779.8 KB
ID:	1154473

    I tried a few ways to go from radius=0 to radius=255(ish, big enough to make the whole material visible on the mesh), but couldnt get it to transition at all, the material would always be not visible. So i thought i did something wrong with my blueprint increasing the radius, but then i just set the radius to a large value (255) to see if it would be visible straight away as it appears it would be in the viewport tab inside the blueprint, but it was not.

    Here is what i had for the blueprint radius increasing thing. (or my attempt at it, i am sure i did it wrong anyway)

    Click image for larger version

Name:	148db98ac516e1364169bb3d506a28b0.png
Views:	1
Size:	367.8 KB
ID:	1154474

    and here is what i see in the game. ( the material inside the red bit should be visible)

    Click image for larger version

Name:	e68403356ae0f0925a40f2529d3028eb.png
Views:	1
Size:	334.1 KB
ID:	1154475

    Here is some information if it helps.

    The material itself: ( I tried learning from these tutorials https://wiki.unrealengine.com/Locati...n_UE4_-_Part_1 and https://wiki.unrealengine.com/Locati...n_UE4_-_Part_2, which worked fine in a separate project, then i copied the material over to this project and tried to make a few adaptions but it is proving unsuccessful so far.
    Click image for larger version

Name:	d5c4a337884fe62da2c654d917e1c04f.png
Views:	1
Size:	566.4 KB
ID:	1154476

    The event tick inside my blueprint:
    Click image for larger version

Name:	9edad3b5cb3884e1dfd73fd82d0e44cd.png
Views:	1
Size:	152.0 KB
ID:	1154477

    Construction script of the blueprint:
    Click image for larger version

Name:	dbccbb2b7f931bcae19c18b2f90d00d6.png
Views:	1
Size:	123.3 KB
ID:	1154478

    Material parameter collection:
    Click image for larger version

Name:	2831ae5774b6342a90403d4922907b76.png
Views:	1
Size:	44.2 KB
ID:	1154479

    If anyone could help with either the lerping from small to large radius, and the problem with the material never being visible (working inside blueprint, but not in game) issue, it would be greatly appreciated.
    Thanks!

    #2
    Sorry to bump but i still have not resolved this issue, and it is really delaying progress. If anyone could help it would be greatly appreciated. Thanks.

    Comment

    Working...
    X