Announcement

Collapse
No announcement yet.

Blueprint Cameras

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blueprint Cameras

    Hi!

    I am trying to do a left mirror for my vehicle in the cockpit view. Actually I made it, but there are things I don't understand. The Camera, ScreenCapture2DComponent and Mirror Mesh is placed 50 cm below where it should be (as it can be seen from the attached picture). However, somehow it works this way, everything in place What is the secret behind it ?

    Thanks!

    Click image for larger version

Name:	Blueprint.jpg
Views:	1
Size:	176.0 KB
ID:	1151895
    Last edited by Bumbala; 06-17-2015, 05:25 PM.

    #2
    The spring arm and the camera position are probably causing some strange things to happen. Personally I wouldn't use a spring arm for this since you want it attached exactly where the mirror is, not having a lag applied to it.

    Comment


      #3
      I did that, but it did not solve the problem. All of them must be placed 50 cm below.

      Comment


        #4
        Hi Bumbala,

        Did you make sure you exported the mirror mesh (from your 3rd party modelling tool) with the mesh placed at the scene world origin (0,0,0)? If you export a mesh not at world origin, the meshes displacement from that point is included in the meshes location in UE4 when attaching it.

        If not this, I guess check your socket/attachment locations. As Zoltan says, with the mirror being child to the spring arm (and not the car mesh), it may well do some funny things (the mirror will be attached to the end of the spring arm, not the vehicle mesh).

        Comment


          #5
          I deleted the spring arm and attached them to the car mesh, but I still have to place them below. The pivot of the mirror is (0, 0, 0) in Maya, but the mesh itself is displaced to its original position on the car. I did like this in order to place it in UE4 easily. First, I tried to attach the material to a surface on the car mesh, but I don't why, it did not work. So, I detached the mirror surface from the car and saved as a seperate mesh, now it works properly. Anyhow, the ScreenCapture2D and Camera are UE4 components, so why do I have to lower them also ? In Maya, the pivot of body and wheels are located at (0, 0, 0). Is it something to do with that ?

          Thanks!

          Note: A bulb lit in my brain and checked the model in Maya. The root bone (Joint_Body) is located at Z=50 cm. Is it something to do with that ?
          Last edited by Bumbala; 06-18-2015, 10:27 AM.

          Comment


            #6
            I would change the root bone (Joint_Body) to have an X, Y and Z value of 0.0

            Comment


              #7
              Yeah that was the problem! I moved root bone to 0, 0, 0 and everything is where it should be

              Thank you very much!

              Comment

              Working...
              X