Announcement

Collapse
No announcement yet.

Character Blueprint has stopped rotating

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Character Blueprint has stopped rotating

    I am playing with the character blueprint in the third person template and for some reason my character has stopped rotating to match the forward vector of the arrow key being pressed. The following screen shots will illustrate the problem.

    In this screen shot I'm holding down the right arrow key. As you can see the character has rotated to face that direction so he runs forward. This is how the default third person character blueprint works.

    Click image for larger version

Name:	right.png
Views:	1
Size:	109.2 KB
ID:	1151025

    For some reason something has changed (I've probably knocked a setting by mistake) in my character blueprint (which is supposed to be identical to the default one used above). Now my character has stopped rotating. In this screen shot I'm again holding down the right arrow key, but now the character stays facing the same direction playing the run animation however he's moving to the right.

    Click image for larger version

Name:	wrong.png
Views:	1
Size:	110.1 KB
ID:	1151024

    I've gone through comparing everything between the two character blueprints and they appear identical so I don't understand why one works and one doesn't. I don't want to just delete the broken one and move on as I like to understand why something is broken and how to fix it as I'm trying to learn this engine.

    Does anyone have any ideas of where I should start looking to find the problem? I bet it is one of the millions of tick boxes somewhere that I've accidentally bumped and have no idea where.

    #2
    There could be a lot of things.

    Have you made Player Rotation "0"?

    Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	14.3 KB
ID:	1079280

    If not, is there any scripting that modifies player's Movement?

    Narg
    http://www.seven-mountains.eu/

    Comment


      #3
      Click on the character movement component - enable " orient rotation to movement"

      Comment


        #4
        I figured it out after watching some video tutorials and I had an "ah ha!" moment. In the class defaults for the character blueprint, there is an option called Use Controller Rotation Yaw, that needs to be turned off (it is turned on by default). The third person template has it turned off correctly, but it was turned on in mine somehow. Don't think I did it as I didn't even know this screen of options existed. The problem actually started after I swapped the mesh out with a different one on my character blueprint, so makes me think it must have reset back to its "on" default state after doing that. If so then that's a nice bu... I mean feature.

        Comment


          #5
          Originally posted by fighter5347 View Post
          Click on the character movement component - enable " orient rotation to movement"
          this did help me . THANKS!!!

          Comment

          Working...
          X