Announcement

Collapse
No announcement yet.

(39) Rama's Extra Blueprint Nodes for You as a Plugin, No C++ Required!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi Rama,

    As I mentioned before, I got the June 10th update working, but the one from the 11th appears to be the same file as the one from the 10th. The folders are exactly the same size, down to the byte. Also, do you know why the new uploads aren't showing on the main list? (I have to delve into the file history for them to show up: http://puu.sh/ilHXw/9ee6014696.png )

    Anyway, thanks for the repeated updates and communication, we <3 you!

    Comment


      Wiki Download Page Issues

      Originally posted by Anaklu View Post
      Hi Rama,

      As I mentioned before, I got the June 10th update working, but the one from the 11th appears to be the same file as the one from the 10th. The folders are exactly the same size, down to the byte. Also, do you know why the new uploads aren't showing on the main list? (I have to delve into the file history for them to show up: http://puu.sh/ilHXw/9ee6014696.png )

      Anyway, thanks for the repeated updates and communication, we <3 you!
      Dear Anaklu,

      That's really odd!

      Here's what I see

      Click image for larger version

Name:	WikiDownloadError.jpg
Views:	1
Size:	316.1 KB
ID:	1079739

      Here's what Community Member Anaklu sees



      Epic can you fix this somehow?

      This explains why people are saying my 4.8 upload is updated for some and others say it is not updated!

      Thanks!

      ~~~

      Here's the link to the wiki page in question
      https://wiki.unrealengine.com/File:VictoryPlugin.zip



      Rama
      Last edited by Rama; 06-12-2015, 03:16 AM.
      100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

      UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

      Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

      Comment


        Media Fire Download That Is Up To Date

        Dear Community,

        Until the issue with the wiki download system is resolved, I've put the latest version of my plugin up on MediaFire!

        You can ensure you have the latest version by using this download link!

        Please note clicking this link will not start a download instantly, it will just take you to the Media Fire file.

        Victory Plugin on Media Fire
        (6/11/15 build from Wiki, 7.91 mb)

        https://www.mediafire.com/?g6uf9kt5ueb2upj

        ~~~

        Epic Wiki Link

        Latest plugin download is here: (7.91 mb)
        https://wiki.unrealengine.com/File:VictoryPlugin.zip


        Enjoy!

        Rama
        Last edited by Rama; 06-12-2015, 03:17 AM.
        100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

        UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

        Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

        Comment


          Thanks Rama! Downloaded and updated to the newest version. Man, that made me feel like a crazy person. Glad it's all figured out now

          Comment


            Originally posted by Rama View Post
            Dear Anaklu,

            That's really odd!

            Here's what I see

            [ATTACH=CONFIG]43304[/ATTACH]

            Here's what Community Member Anaklu sees



            Epic can you fix this somehow?

            This explains why people are saying my 4.8 upload is updated for some and others say it is not updated!

            Thanks!

            ~~~

            Here's the link to the wiki page in question
            https://wiki.unrealengine.com/File:VictoryPlugin.zip



            Rama
            Hi I can confirm I was seeing the same thing. I will try the new link.

            Thanks
            Isaac Nichols
            Game Developer & Music Producer - Threaded Pixel Studios
            Currently working on Drones & Ruins a Sci-Fi twin-stick shooter.

            Comment


              Yeah Rama it's blueprint/content-only project with full rebuild on, I got the same error on a new project. But it only happens when I've got your plugin enabled. I even tried reinstalling 4.8 and tried a new project again, same thing.

              Edit: Appears I'm not alone with that link error. https://answers.unrealengine.com/que...ing-in-48.html
              Last edited by Tekoppar; 06-12-2015, 05:35 AM.

              Comment


                Hey quick question, I'm installing the plugin step by step but it just doesn't work in the editor. It shows up on the plugin list, it's enabled, config line is added, editor restarted... I tried it on different computers, same effect, cannot find any errors etc.
                I used an older version of VP couple builds ago and it worked fine. Thanks for any advice!

                Comment


                  The june 11th 7.91mb version shows up fine on the website, and loads/runs/etc. just fine in both C++ and BP based new and old projects for me.

                  As to the linking errors. I only got those when I had bad code as in errors, and to the response on that thread "I disabled the substance plugin" I have the 4.8 substance-ue4 plugin installed in all my projects :S
                  Tek LLC a personal Candaian Company running BlenderTek & UnrealTek is currently looking for help to bring back submarine simulator gaming with a new genre of sub sims: Cold War! (1945-1991) Operation: Trident SubSim Dev Diary Thread - Donations

                  Comment


                    I guess the wiki link was still broken when I downloaded it or something, tried it now with the mediafire link and it compiles fine.

                    Just tested downloading the 11th june 7.91mb version from the wiki and from the mediafire and the mediafire one appears to be newer then the wiki one, it's files are bigger and have newer dates then the wiki one.

                    Edit: Just tried it again with both links on new projects and now I suddenly can't get it to work again.

                    Edit2: Found out that if I verify my 4.8 version I can package new projects until I attempt to package my 4.7.6 project which somehow breaks it for all projects.
                    Last edited by Tekoppar; 06-12-2015, 10:41 AM.

                    Comment


                      I'm having no problems with the wiki link on fresh projects or old. Make sure you select engine version -> 4.8 on any old projects first, and try deleting ALL intermediate folders, or are you talkuing about just linking errors?
                      Tek LLC a personal Candaian Company running BlenderTek & UnrealTek is currently looking for help to bring back submarine simulator gaming with a new genre of sub sims: Cold War! (1945-1991) Operation: Trident SubSim Dev Diary Thread - Donations

                      Comment


                        Originally posted by Tekoppar View Post
                        I guess the wiki link was still broken when I downloaded it or something, tried it now with the mediafire link and it compiles fine.

                        Edit2: Found out that if I verify my 4.8 version I can package new projects until I attempt to package my 4.7.6 project which somehow breaks it for all projects.
                        These are very strange errors indeed!

                        Please post on Answerhub about this!

                        It sounds like it could be related to the new unification of all Editor Settings across all projects (and apparently all versions?)


                        Rama
                        100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

                        UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

                        Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

                        Comment


                          Originally posted by Ozzie View Post
                          Hey quick question, I'm installing the plugin step by step but it just doesn't work in the editor. It shows up on the plugin list, it's enabled, config line is added, editor restarted... I tried it on different computers, same effect, cannot find any errors etc.
                          I used an older version of VP couple builds ago and it worked fine. Thanks for any advice!
                          Welcome ot the forums Ozzie!

                          "Hey quick question, I'm installing the plugin step by step but it just doesn't work in the editor"

                          Can you explain more? What's not working? BP nodes not showing up or the vertex snap editor not working?

                          Please make sure you are using 4.8 and download from my Media Fire link due to issues with wiki download system for some people / browser cache stuff

                          You can ensure you have the latest version by using this download link!

                          Please note clicking this link will not start a download instantly, it will just take you to the Media Fire file.

                          Victory Plugin on Media Fire
                          (6/11/15 build from Wiki, 7.91 mb)

                          https://www.mediafire.com/?g6uf9kt5ueb2upj

                          Have fun today!

                          Rama
                          100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

                          UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

                          Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

                          Comment


                            Click image for larger version

Name:	HasSubstring.jpg
Views:	1
Size:	192.1 KB
ID:	1079712
                            (as of 6/11/15)


                            Reminder of my new node that I just released amidst all the support posts

                            Dear Community,

                            I've made a new BP node for you!

                            HasSubstring compliments the functionality of FindSubstring.

                            FinsSubstring requires more inputs and returns an index within the source string.

                            My node, HasSubstring, requires only 1 input and only returns whether or not the supplied substring is in the source string.

                            I use the C++ version of HasSubstring all the time so I felt you would all enjoy having it in BP as well!

                            ~~~

                            Example Usage ~ Search Feature

                            If you wanted to make a string-based search feature, that iterated over the contents of a list of UMG Texts, you can take the user's supplied search string and use my HasSubstring node to find all the UMG Text widgets that contain the user's supplied search string.

                            ~~~

                            Latest plugin download is here: (about 8 mb)
                            https://wiki.unrealengine.com/File:VictoryPlugin.zip

                            ~~~

                            You can ensure you have the latest version by using this download link!

                            Please note clicking this link will not start a download instantly, it will just take you to the Media Fire file.

                            Victory Plugin on Media Fire
                            (6/11/15 build from Wiki, 7.91 mb)

                            https://www.mediafire.com/?g6uf9kt5ueb2upj

                            Enjoy!



                            Rama
                            100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

                            UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

                            Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

                            Comment


                              Yeah got an answer on answerhub already. https://answers.unrealengine.com/que...ing-in-48.html

                              Comment


                                Packaging Plugins for upgraded project in 4.8, Workaround

                                Dear Community,

                                Here's the solution to the packaging with plugins errors that Tekoppar posted:

                                Originally posted by Tekoppar View Post
                                MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [11/12] Link UE4-VictoryBPLibrary.lib
                                MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [12/12] Link Project542352352.exe
                                MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: LINK : fatal error LNK1181: cannot open input file 'C:\Program Files\Unreal Engine\4.8\Engine\Intermediate\Build\Win64\UE4\Development\Launch\PCLaunch.rc.res'
                                ~~~

                                Epic Response on Answerhub

                                Originally posted by Epic Staff Pete View Post
                                Ok, there is definitely an issue in 4.8. We're looking in to a fix. In the meantime, you can fix the issue by the following:

                                Create a new code-based project (the template chosen doesn't matter, I chose FPS)

                                After the newly created project has been opened in the editor, use explorer to browse to the location of that project on your computer

                                Search for PCLaunch.rc.res in that project (it will be found in the Intermediate directory)

                                Copy that file to /Engine/Intermediate/Build/Win64/Development/Launch/ and/or /Engine/Intermediate/Build/Win32/Development/Launch/ (you may have to make the Launch directory)

                                Open the broken project

                                Uncheck Rebuild in the Package Settings

                                Package should now work

                                Not ideal, but should get you unbroken and still be able to have the enabled plugins.

                                -Pete
                                Full Thread
                                https://answers.unrealengine.com/que...ing-in-48.html




                                Rama
                                Last edited by Rama; 06-12-2015, 02:03 PM.
                                100+ UE4 C++ Tutorials on the UE4 Code Wiki, including UE4 Multi-Threading!

                                UE4 Marketplace: Melee Weapon Plugin & Compressed Binary Save System Plugin | Rama's C++ AI Jumping Videos | Vertex Snap Editor Plugin

                                Visit www.ue4code.com to see lots of videos about my C++ Creations! ♥ Rama

                                Comment

                                Working...
                                X