Announcement

Collapse
No announcement yet.

(39) Rama's Extra Blueprint Nodes for You as a Plugin, No C++ Required!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Will be testing 4.22 now....
    Last edited by Thunder_Owl; 06-11-2019, 03:04 PM. Reason: Edited, because i was stupid

    Comment


      Hi all, and thanks Rama for such a great plugin!

      I wondered if anyone would have some advice: I installed the plugin for 4.22 like two weeks ago, I had some doubts but it even works for 4.00.2!
      What I needed was a way to move and rename a screenshot, so I discovered the 'Screen Shots Rename Move Most Recent' node, which is perfect and does just that!

      Playing with it for some time, linking it to my other nodes, it works well! Except when I package my project as Develoment or Shipping, then the node won't work. Actually it will half work because it still manages to create a folder following a custom naming, but won't manage to rename and move the screenshot.

      So I investigated some things, I tought it may have to do with the default Screenshots folder maybe. The node knows whatever default Screenshots folder I use while I'm in Unreal - but I guess it's lost at runtime and can't seem to see any other folder than the 'default' default folder, which would be something like C:\Users\(User name)\AppData\Local\(Project Name)\Saved\Screenshots\WindowsNoEditor

      But even that 'default folder' will stay empty -- I manage to create new folders inside, but no screenshot goes there in the first place, so no screenshot is moved either.

      An other question for those who know would be, where exactly is the Screenshots folder location at Runtime?
      Maybe I forgot something, does anyone know if I'm doing something wrong?

      Thanks all!
      Attached Files

      Comment


        No point in writing here anymore. Several nodes are broken in shipping as well. Rama has stopped giving a ****.

        Comment


          Originally posted by Blue669 View Post
          No point in writing here anymore. Several nodes are broken in shipping as well. Rama has stopped giving a ****.
          This is free plugin...he has to earn a living...so, maybe he's working on paid stuff...you can review the source code yourself to see if you can fix / add features.

          teak
          "A little bit of nonsense now and then is cherished by the wisest men..."
          -- Willy Wonka

          Smooth Zoom Camera Plugin for 4.22 here.

          Comment


            Originally posted by Bob3DGames View Post
            Still getting error "LogPluginManager: Warning: Plugin 'VictoryBPLibrary' is not compatible with the current engine version (4.22.0)" when trying to open engine version 4.22.2.
            You've most likely already checked...but...have you opened the .uplugin file in a text editor and make sure that the version is set to 4.22.0?

            teak
            "A little bit of nonsense now and then is cherished by the wisest men..."
            -- Willy Wonka

            Smooth Zoom Camera Plugin for 4.22 here.

            Comment


              Originally posted by teak421 View Post

              This is free plugin...he has to earn a living...so, maybe he's working on paid stuff...you can review the source code yourself to see if you can fix / add features.

              teak
              You should know as well as I do that it's not so easy to just go into somone's source code and fix / add features yourself.

              The point that Rama has stopped working on this is not an isolated issue. It goes through the whole marketplace as well, because many items there are now useless because the creator isn't getting as much out of it anymore to give a **** about it and stop working on it. It's a shame. I can't afford pushing updates of my games back because some marketplace dev doesn't update his plugins anymore. But ultimately it made me stop using any 3rd party plug-ins for good. In the specific case of this plugin, many very valuable things from this have already been adapted into the official UE4 build, so there is less and less reason to keep using it.

              Maybe that's why Rama gave up on it.
              And just to be clear - I think Rama is a great guy who's dedication to his work is commendable. I fully understand why he would eventually abandon his older work like this, because there is just nothing in it for him anymore to keep working on it.

              PS: Please fix the "get pixel rgb from texture" node, it's broken in shipping build
              Last edited by Blue669; 06-21-2019, 04:12 AM.

              Comment


                Originally posted by Blue669 View Post

                You should know as well as I do that it's not so easy to just go into somone's source code and fix / add features yourself.

                The point that Rama has stopped working on this is not an isolated issue. It goes through the whole marketplace as well, because many items there are now useless because the creator isn't getting as much out of it anymore to give a **** about it and stop working on it. It's a shame. I can't afford pushing updates of my games back because some marketplace dev doesn't update his plugins anymore. But ultimately it made me stop using any 3rd party plug-ins for good. In the specific case of this plugin, many very valuable things from this have already been adapted into the official UE4 build, so there is less and less reason to keep using it.

                Maybe that's why Rama gave up on it.
                And just to be clear - I think Rama is a great guy who's dedication to his work is commendable. I fully understand why he would eventually abandon his older work like this, because there is just nothing in it for him anymore to keep working on it.

                PS: Please fix the "get pixel rgb from texture" node, it's broken in shipping build
                I went back a few pages and I couldn't find anything posted by you... (maybe further back), so apologies if you already put forward what is not working... Anyway, are you using the "get pixel rgb from texture" node or are you not using it but it is preventing you from creating a shipping build and if it was removed, the problem would be solved?

                teak
                "A little bit of nonsense now and then is cherished by the wisest men..."
                -- Willy Wonka

                Smooth Zoom Camera Plugin for 4.22 here.

                Comment


                  Just popping in to say thank you!
                  Was able to write to and read from logs quite easily thanks to this thread and all contributors here.
                  Last edited by NotSoAccurateNo1; 06-26-2019, 05:29 PM.

                  Comment


                    Has anybody noticed a performance impact when using the "LoadTexture2DFromFileExtension" Node? I've done a bunch of profiles of texture srteaming, GPU and CPU profilers and it seems to have little to no impact on performance compared to either other actors with dynamic materials, or completely static actors with a standard material instance.

                    Comment


                      Originally posted by teak421 View Post

                      I went back a few pages and I couldn't find anything posted by you... (maybe further back), so apologies if you already put forward what is not working... Anyway, are you using the "get pixel rgb from texture" node or are you not using it but it is preventing you from creating a shipping build and if it was removed, the problem would be solved?

                      teak
                      Other people have posted this issue 2 times already, so I didn't want to post it a third time.

                      The node itself works fine in the editor, but in the shipping build it always returns 0 and I have no idea why.

                      I was using it to determine blocked paths on a minimap and it would be a great artistic way to draw special points on a map that has influence on the gameplay, but it doesn't work in shipping.

                      I'm using a different method now by just filling an array with coordinates (more time consuming and less awesome).
                      Last edited by Blue669; 07-05-2019, 04:51 AM.

                      Comment


                        Hey,

                        i'm currently using a self-made plugin combined with the victory plugin in 4.21 in c++.
                        I have made custom dependencys adding victory plugin to my self-made plugin .uplugin & .build.cs, so i can use the CaptureComponent2D_SaveImage() function.

                        Editor is starting fine out of VS17, but if i now try to build the project, i'll always get an "C1083: include cound't be opend: "AIController.h" No such file or directory.

                        I can change the import to "Runtime/AIModule/Classes/AIController.h", but then there are a couple of includes missing in "AIController.h"

                        Anybody got an idea why this is happening?
                        Do i have to change every import path manually?
                        Last edited by MarlinAtRevis3d; 07-11-2019, 05:38 AM.

                        Comment


                          Why is this not on the marketplace ?

                          Comment


                            Originally posted by inedible.red View Post
                            Why is this not on the marketplace ?
                            Because there is another package already available that does similar things...its also free. There is another BP only package that tried to get on the MP but was denied for that reason.

                            teak
                            "A little bit of nonsense now and then is cherished by the wisest men..."
                            -- Willy Wonka

                            Smooth Zoom Camera Plugin for 4.22 here.

                            Comment


                              "capture component 2d save image" is not saving alpha in PNG and it's crashing using BMP

                              Comment


                                Originally posted by inedible.red View Post
                                "capture component 2d save image" is not saving alpha in PNG and it's crashing using BMP
                                Well i tried using it in BP and it worked just fine.
                                Now i'm trying to do the same thing in c++ with the exact same data and like i said i can't event build the project because of missing includes in my own plugin but located at Victorys Plugin.

                                Comment

                                Working...
                                X