Announcement

Collapse
No announcement yet.

Blueprint scenes (maps) with and without a character spawned

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blueprint scenes (maps) with and without a character spawned

    Hello,

    I use the Blueprint Third Person Template and I created the three scenes: one with Main Menu, and the others with the character spawned at runtime. When I start from the Main Menu scene, the character is spawned automatically here too and I can shoot. How to do not to spawn the character in the first scene? And, for example, how to make a splash screen without the character and shooting? Because the character (and other stuff ) is spawned on every created scene automatically. Are there a possibility to make scenes with the spawned character and without?

    #2
    By Scene are you meaning Level? Because you should be able to set things on a per level basis quite easily to use different cameras etc or you could take over with matinee.

    Comment


      #3
      Originally posted by ZoltanJr View Post
      By Scene are you meaning Level? Because you should be able to set things on a per level basis quite easily to use different cameras etc or you could take over with matinee.
      yes, I mean Level. I have used Unity and now I'm trying to develop with UE4. Do you mean Level Blueprints saying 'on a per level basis'? But the character is spawned on all levels automatically. How to switch the character off on a level? I know I can add different actors on a per level basis. I use HUD, for example, on a per level basis. But the character is spawned on every level I create because it is driven by Game Mode. In Unity it's easy - you just place the character on a level or not. I'm trying to find the info in Google, but so far I'm unsuccessful.

      Comment


        #4
        Try dropping a camera into your level and setting it to auto activate for player 0. Then on the level start disable input for your player character. Thats the quickest way to make it work anyway. But you should also be able to adjust the gamemode per map too with the GameMode Override in the world settings which I believe is probably the more "correct" way of doing things.

        Comment


          #5
          Originally posted by ZoltanJr View Post
          Try dropping a camera into your level and setting it to auto activate for player 0. Then on the level start disable input for your player character. Thats the quickest way to make it work anyway. But you should also be able to adjust the gamemode per map too with the GameMode Override in the world settings which I believe is probably the more "correct" way of doing things.
          Thank you. Ok, I'll try. Is GameMode in the world settings for a level or for the whole game? In other words, every level has (can have) its own GameMode. Or just on some levels the GameMode can be switched off. I thought one GameMode is for the whole game, but maybe I was wrong.

          EDIT:

          World Settings are global as I thought, so when I set the Default Pawn Class to None, the character disappears on every level.

          EDIT:
          I have added the camera into my level and set it to activate for player 0, but how to disable input for my player character on one level?
          Last edited by Tomza; 04-30-2015, 02:56 AM.

          Comment


            #6
            You can definitely do gamemode overrides on a per level basis I just tested it out again to make sure.
            Pull up your world settings (It should show up next to the details panel tab if you have the default layout, then select a different gamemode for the GameMode Override, or select the same mode and just change the pawn class or whatever else you want and this is just done per level.

            Comment


              #7
              Originally posted by ZoltanJr View Post
              You can definitely do gamemode overrides on a per level basis I just tested it out again to make sure.
              Pull up your world settings (It should show up next to the details panel tab if you have the default layout, then select a different gamemode for the GameMode Override, or select the same mode and just change the pawn class or whatever else you want and this is just done per level.
              Yeah, you are right! I have just chosen a GameMode for the Game Mode Override in the World Settings for the Main Menu Level. And the character disappeared on this level, but he still exist on the other levels. It's exactly what I wanted. Earlier, I just chose None for the Game Mode Override in the World Settings for the Main Menu Level and the character disappeared on all three levels. Thank you for your precious help. Now, I understand how it works. The World Settings can be overridden. Unreal works completely in a different way than Unity does. Thank you again, ZoltanJr.

              Comment

              Working...
              X