Announcement

Collapse
No announcement yet.

Setting Actor Transform Disables Collision?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Setting Actor Transform Disables Collision?

    Hello all! I have some objects that I'm trying position using blueprints, and using Set Actor Transform (or any function that changes it's position or rotation) seems to remove the blueprint's collision. Any help? Thanks!

    #2
    *bump* :-)

    Comment


      #3
      Without knowing exactly what is going on, this is hard to debug. This could be anything from a mis-set collision channel to a full on engine bug. We need screenshots, blueprints, whatever would help us debug your problem.

      Comment


        #4
        Maybe the collision box area is not moving with the actor for some reason? Check if there is an invisible colliding object in the actor's 1st location.
        Marketplace Assets

        Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
        Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
        Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

        Comment


          #5
          I checked and the collision does not move with the actor. Really weird.

          Comment


            #6
            Is the collision built into the actor? Or did you spawn some sort of shape around the actor to act as collision?
            Marketplace Assets

            Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
            Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
            Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

            Comment


              #7
              It could be that the collision is not under the box in the hierarchy if so then you need to move the collision instead and the box should follow.
              Please show blueprint

              Comment


                #8
                Originally posted by Jamendxman3 View Post
                Is the collision built into the actor? Or did you spawn some sort of shape around the actor to act as collision?
                The collision is in the static meshes themselves. My blueprint is made up of instanced static mesh components and now derived from a class I wrote in C++.
                Click image for larger version

Name:	Untitled.png
Views:	1
Size:	846.8 KB
ID:	1075226
                I'm still getting the same results. Setting the actor's transform seems to leave the collision behind.
                Code:
                SetActorLocation(OtherAttachmentPoint->GetComponentLocation());
                SetActorRotation(FRotator(0, OtherAttachmentPoint->GetComponentRotation().Yaw, 0));
                I wonder if it has to do with me using instanced static mesh components. I'm going to try switching everything to a regular static mesh component and see if that fixes it. I'll report back here with the results.

                Comment


                  #9
                  Just tried it out, and using regular static mesh components fixes it. But Instanced Static Mesh Components don't move the collision. :/

                  Comment

                  Working...
                  X