Announcement

Collapse
No announcement yet.

[Paper2D] Sprite gets stuck on the bottom of the screen

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [Paper2D] Sprite gets stuck on the bottom of the screen

    I have this setup:

    Click image for larger version

Name:	93f858fe83.jpg
Views:	1
Size:	210.7 KB
ID:	1148668

    But when the Sprite reaches the bottom of the screen as seen here:

    Click image for larger version

Name:	39c0c9c812.png
Views:	1
Size:	78.2 KB
ID:	1148669

    Click image for larger version

Name:	12e1211db5.jpg
Views:	1
Size:	82.9 KB
ID:	1148670

    I can no longer move at all. I am just stuck there. This doesn't happen if I hit the top of the screen. Anyone got a clue?

    #2
    How big is your file-size? Would you like help debugging it? What if you plug an obscene number into the Z for up?

    Comment


      #3
      Originally posted by The Britain View Post
      How big is your file-size? Would you like help debugging it? What if you plug an obscene number into the Z for up?
      How big is my file-size..?

      Comment


        #4
        Originally posted by Vipar View Post
        How big is my file-size..?
        If you zipped up your project, how big is it? If it is not to large, I wouldn't mind giving it a quick look over. We did a similar style game for the Game Jam, and it sounds like you hit a similar snag.

        Comment


          #5
          Originally posted by The Britain View Post
          If you zipped up your project, how big is it? If it is not to large, I wouldn't mind giving it a quick look over. We did a similar style game for the Game Jam, and it sounds like you hit a similar snag.
          I sent you a PM

          Comment


            #6
            Oh wow. So I figured out what it was. When you come to the bottom of the Z axis, and you collide with something, it essentially is waiting for you to jump. By adding a jump node to the end of the "Up" function, I got it to work.

            UNREAL DEVS: Is there a way to disable jump completely so this doesn't happen with other projects?

            Click image for larger version

Name:	wow.png
Views:	1
Size:	122.8 KB
ID:	1075202

            Comment


              #7
              For your projectile, you need to set the velocity and speed, and tell the rotation to follow velocity.
              Also, make sure to turn your sprite over if that's what you want.

              Click image for larger version

Name:	Projectile.png
Views:	1
Size:	212.7 KB
ID:	1075203

              Comment


                #8
                Originally posted by The Britain View Post
                Oh wow. So I figured out what it was. When you come to the bottom of the Z axis, and you collide with something, it essentially is waiting for you to jump. By adding a jump node to the end of the "Up" function, I got it to work.

                UNREAL DEVS: Is there a way to disable jump completely so this doesn't happen with other projects?

                [ATTACH=CONFIG]36650[/ATTACH]
                That is..very odd.. ._.
                Do I actually have to jump at the end then? Or does it just fire the jump and you won't notice it?

                Originally posted by The Britain View Post
                For your projectile, you need to set the velocity and speed, and tell the rotation to follow velocity.
                Also, make sure to turn your sprite over if that's what you want.

                [ATTACH=CONFIG]36651[/ATTACH]
                But I apply these things in the blueprint which worked just fine before. So doing that should not be necessary:

                Comment


                  #9
                  I didn't notice any jumping, but it does get it away from, what basically, Unreal considers a floor. It's not an ideal solution.

                  Comment


                    #10
                    Originally posted by The Britain View Post
                    I didn't notice any jumping, but it does get it away from, what basically, Unreal considers a floor. It's not an ideal solution.
                    It also makes ascending again slower until you stop or descend before ascending again.
                    And not only that, if you ascend after the jump and you want to switch directions, the ship will stop until you release the directional key you were going in and press it again. Making it very clunky.

                    Comment


                      #11
                      Originally posted by Vipar View Post
                      It also makes ascending again slower until you stop or descend before ascending again.
                      And not only that, if you ascend after the jump and you want to switch directions, the ship will stop until you release the directional key you were going in and press it again. Making it very clunky.
                      I will continue to play to see how this can be removed, or at least re-orient the gravity in another direction.

                      Comment


                        #12
                        Originally posted by The Britain View Post
                        I will continue to play to see how this can be removed, or at least re-orient the gravity in another direction.
                        Thank you. This is really mind-boggling. Almost makes me want to just look into Unity 2D framework. The time and effort it takes to make something simple in UE4 seems unreasonable at the moment :c

                        Comment


                          #13
                          What is your movement mode set to? If you guys are able to jump I'm assuming it is walking movement mode which also happens to include floor checks. What happens if you switch your default land movement to flying? This will disable gravity and floor checks.

                          I am suffering from a similar issue where when flying against a walkable surface my character gets stuck to the terrain, the issue being when my capsule touches the terrain it switches me back to walking mode
                          Last edited by DEDRICK; 04-27-2015, 12:39 PM.

                          Comment


                            #14
                            Okay I found a fix that doesn't need to use the Jump hack-fix

                            I went into the Character Movement Component and found the two options:

                            Click image for larger version

Name:	6d939d151d.png
Views:	1
Size:	2.6 KB
ID:	1075228

                            Changing them to Flying fixed it. The movement can still be a little choppy at times but it's minimal.

                            And now with these changes I can go back to this simple Bluescript (as I like to call it) instead of the unnecessary complex one:

                            Click image for larger version

Name:	23f46a838e.jpg
Views:	1
Size:	48.7 KB
ID:	1075229

                            I just have to do a few changes to the Movement Component:

                            Click image for larger version

Name:	fa57b24303.png
Views:	1
Size:	3.4 KB
ID:	1075230
                            Last edited by OmniOwl; 04-27-2015, 03:36 PM.

                            Comment


                              #15
                              Hah, I knew it. There is something with walking movement that causes you to stick to surfaces even with 0 friction. I made a video showing the issue

                              https://www.youtube.com/watch?v=edB8BNFdyDs

                              Comment

                              Working...
                              X