Announcement

Collapse
No announcement yet.

Input from button pressed isn't working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Input from button pressed isn't working

    I think this will have an easy solution that I'm missing but my mind has gone blank over this.

    I have a little set up where you walk up to some objects and when you interact with them, your camera switches to one set up above these objects to act as an in-engine menu. From here, you can toggle between each object selection and pick one. My problem is, I want to move/switch between each object in the "menu" with A and D for left and right.

    "D pressed" isn't firing though (Input is enabled), which I assume has something to do with the fact that 'D' is also the input for first-person character movement in the project. What am I missing that allows my D pressed in the blueprint to ignore the character movement and fire off? Thanks!

    #2
    You should probably check fr something called consume input. I don't remember it it's in the input otself or the pawn, but that may be what you're looking for. Basically, if An input is consumed, it stops there and won't fire any event in other entities.

    Comment


      #3
      If you could show me the blueprint in question, I might be able to help you. It is difficult to backtrack the problem without seeing the blueprint .
      UE4 game developer.

      Creator of the WIP "Freezing hell": https://forums.unrealengine.com/show...-Freezing-hell

      Comment


        #4
        Originally posted by killfassil View Post
        You should probably check fr something called consume input. I don't remember it it's in the input otself or the pawn, but that may be what you're looking for. Basically, if An input is consumed, it stops there and won't fire any event in other entities.
        I have 'Consume Input' checked on the 'D Pressed' input node within the blueprint. Do you mean that or is there a similar checkbox elsewhere?

        Originally posted by kirahirasai View Post
        If you could show me the blueprint in question, I might be able to help you. It is difficult to backtrack the problem without seeing the blueprint .
        Sorry about that, here's a quick screengrab. I threw a log in straight after the input node but it doesn't fire at all :/

        Click image for larger version

Name:	9482e8e1872e60e3bdbc67158dc5dc7e.png
Views:	1
Size:	159.7 KB
ID:	1074876

        Comment


          #5
          Did you try to remove the "branch" node and plug the "pressed" node directly into the "set" node? That may indicate a problem with the boolean. Is the d key working in your other programs? Just to make sure, your keyboard isn't defective.
          Last edited by kirahirasai; 04-21-2015, 08:37 PM.
          UE4 game developer.

          Creator of the WIP "Freezing hell": https://forums.unrealengine.com/show...-Freezing-hell

          Comment


            #6
            Originally posted by killfassil View Post
            You should probably check fr something called consume input. I don't remember it it's in the input otself or the pawn, but that may be what you're looking for. Basically, if An input is consumed, it stops there and won't fire any event in other entities.
            AHA!

            I just went into my Controller blueprint, found the 'InputAxis Movement' nodes and unticked the 'Consume Input' on those and it works now! Thank you very much for pointing me in the right direction!

            Click image for larger version

Name:	b8a207a957530d10e7772f0c7f4dbad4.png
Views:	1
Size:	29.9 KB
ID:	1074877

            Thank you both for helping

            Comment


              #7
              Glad to hear it . Have fun with your project.
              UE4 game developer.

              Creator of the WIP "Freezing hell": https://forums.unrealengine.com/show...-Freezing-hell

              Comment


                #8
                I too had this problem. I couldn't find the Controller blueprint but found another way to fix this.

                My keyboard input code is in the PlayerStart_Blueprint. So I selected the PlayerStart and in its details, under Input, I changed Auto Recieve Input from Disabled to Player 0

                Click image for larger version

Name:	PlayerStart.png
Views:	669
Size:	23.7 KB
ID:	1701545

                Comment

                Working...
                X