Announcement

Collapse
No announcement yet.

Blueprint opening empty

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blueprint opening empty

    Hi,

    I'm following this tutorial : https://wiki.unrealengine.com/First_...st_Person_Mesh

    And I'm at this step :

    1. Click on Save in the Content Browser to save your new Skeletal Mesh and its associated assets.

    2. Navigate back to the Blueprints folder in the Content Browser.

    3. Open BP_FPSCharacter and switch to Components Mode.

    (NOTE: There is an additional step required as a workaround to an current issue we are looking into. To be able to find the FirstPersonMesh in the component list, you will need to delete the BP_FPSCharacter blueprint and recreate it. After doing this you can continue with step 4.)

    4. Find the new FirstPersonMesh we added. Notice that it is a child of the FirstPersonCameraComponent, so it will always be attached to the camera. You may have to expand the FirstPersonCameraComponent dropdown.
    Click image for larger version

Name:	n2.jpg
Views:	1
Size:	76.5 KB
ID:	1148375

    but when I click on Bp_FPSCharacter I only get an empty window, I trie window>reset layout but this did nothing.
    Any ideas?

    Thanks.

    #2
    I suggest re-creating your BP. If this does not work, then you must've saved your current layout, which would explain why resetting layout would not do anything. I suggest you reset your prefs
    Marketplace Assets

    Advanced Mobile Input: Marketplace Page | Support Thread ――― Easy Input Remapping: Marketplace Page | Support Thread
    Multiplayer Blueprint Chat System: Marketplace Page | Support Thread ――― Closing Credits System: Marketplace Page | Support Thread
    Minesweeper Template: Marketplace Page | Support Thread ――― Maze Creator: Marketplace Page | Support Thread

    Comment


      #3
      Originally posted by Jamendxman3 View Post
      I suggest re-creating your BP. If this does not work, then you must've saved your current layout, which would explain why resetting layout would not do anything. I suggest you reset your prefs
      recreating it worked, thanks

      However each times I close UE4 and get back to it I have to recreate the BP in order to see what's inside, quite bothersome

      Comment


        #4
        From this post: https://answers.unrealengine.com/que...or-bluepr.html


        If you open a blueprint and the view is mostly blank like above use the menu of that blueprint editor window and click on Window->Class Defaults

        This will show you a message at the top that says "Note: This is a data only blueprint, so only the default values are shown. It does not have any script or variables. If you want to add some, Open the Full Blueprint Editor"

        Click the blue link that reads "Open the Full Blueprint Editor." You will now be able to use that blueprint again like normal.

        Why this is happening I do not know. But this will help you get around this bug.

        Comment

        Working...
        X