Announcement

Collapse
No announcement yet.

Weird thing about actor transformation and editor views

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weird thing about actor transformation and editor views

    Hi all!



    As the image shows, my spaceship is facing forwards (red arrow), but the front and side view seems to be wrong (the front view should be showing the spaceship facing you, i think).
    This is normal or i'm doing something wrong? :S.

    See ya!

    #2
    No one has an idea? .
    Ahm, one more thing: What is that white sphere which appears above the spaceship? I haven't placed any sphere there and it doesn't appear when i go to play in editor mode :S.

    See ya!

    Comment


      #3
      Bump, i still have hope. Pleeeease, any clue? .

      See ya!

      Comment


        #4
        I think i have found the solution .

        Firstly, the reason i thought the viewports were wrong, is because, when i made my actor move forward (being oriented as the viewports icons shows), it moved sideways.
        The reason seems to be that i was moving the actor with the "Add Actor Local Offset" node.

        I have tried now to move with the "Set Actor Location" after getting its forward vector and adding it to its current location, and now, it moves correctly.

        What does surprise me is that the thread reached many views and no one replied that the viewports were right :S.

        See ya!

        Comment

        Working...
        X