Announcement

Collapse
No announcement yet.

Got damage to register, no destroy.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Got damage to register, no destroy.

    I got my damage working with my projectile but after the health gets to 0, it just prints the string for the death but doesn't actually destroy the player. Any help would be greatly appreciated. (P.S. This Blueprint is my MyCharacter blueprint.)Click image for larger version

Name:	screenshot.png
Views:	1
Size:	208.5 KB
ID:	1144609

    The error message is also: Error Cannot access 'CollisionComponent'. It is pending kill. Property: 'K2Node_Event_OtherComp' from node Set lastSpawn in blueprint MyCharacter

    #2
    Just shooting in the dark here, but what happens if you unplug 'Get Owner' from 'Destroy Actor'? I tried it on my end with the 3rd person template, and it seems to be working. 4.7prev8 not networked.

    Comment


      #3
      Originally posted by The Britain View Post
      Just shooting in the dark here, but what happens if you unplug 'Get Owner' from 'Destroy Actor'? I tried it on my end with the 3rd person template, and it seems to be working. 4.7prev8 not networked.
      Nothing happens, same thing. But I do think I know what is happening. My respawn event is being cancelled because it is being overlapped by the destroy actor event. I'll show you my respawn function.

      Click image for larger version

Name:	ss+(2015-02-21+at+02.34.01).png
Views:	1
Size:	264.6 KB
ID:	1066889

      Comment

      Working...
      X