Announcement

Collapse
No announcement yet.

Help: Camera Zoom 1ST Person.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help: Camera Zoom 1ST Person.

    Hi All

    I have been looking around and unable to find a tutorial on how to set a ZOOM function for 1st Person.

    I tried to amend a 3rd person one without success.

    I added a Swing Arm, but had to rotate it 180 so location was 0/0/0 in reference to the camera

    Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	52.7 KB
ID:	1144526

    I tried this script off right mouse button. It is being called

    Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	38.3 KB
ID:	1144525

    I thought about putting a another camera in the BP about 300 ahead on X and just changoing camera, but do not how to do that either

    Any Help would be appreciated.

    Narg
    http://www.seven-mountains.eu/


    #2
    This should work if you make the camera a child of the spring arm component. At the moment the spring arm is a child of the camera.
    [FREE] Procedural Bridge Blueprint, [FREE] Spline Enabled Ivy BP

    Comment


      #3
      Actually, your mesh is also set to be a child of the camera, therefore when zooming your arms will still be visible....you'll probably want to make the spring arm a child of the mesh and the camera the child of the spring arm. Also, when changing the value of the arm length, if you interpolate between the values it will be a smooth transition.

      I hope this helps
      [FREE] Procedural Bridge Blueprint, [FREE] Spline Enabled Ivy BP

      Comment


        #4
        I think what you are actually trying to do is zoom the camera from its current position? for that you probably just want to manipulate the FOV. Have a look for the term FOV off the camera.

        Comment


          #5
          Hi All

          Thanks for the feed back

          Just looking at a like a scope. Just jump to Zoom. E.g. 500

          Works fine until I get around Meshes

          Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	74.2 KB
ID:	1066789

          Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	54.6 KB
ID:	1066790

          In the video, when I walk around the trees, I am not hitting Right Mouse button.



          Narg
          http://www.seven-mountains.eu/

          Comment


            #6
            As zoombapup said, I think you are actually trying to do something like this?
            Click image for larger version

Name:	ZeN2xbl.png
Views:	1
Size:	112.6 KB
ID:	1066791
            That's a .5 second long timeline, that has a float track, 0 at 0 seconds and 40 at .5 seconds. It reduces your characters FOV when right click is pressed, so it "zooms in".

            Unless for some reason you actually need to move the camera
            Last edited by Mosel3y; 02-20-2015, 07:12 AM.

            Comment


              #7
              Zoombapup and Mosel3y are correct, changing the FOV is the way to go with this.
              [FREE] Procedural Bridge Blueprint, [FREE] Spline Enabled Ivy BP

              Comment


                #8
                Hi All

                Where is the "Player FOV" VAR and what does it do, no node to find, Is it a VAR, if so, what should it be connected to?

                Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	68.8 KB
ID:	1066792

                Thanks Again

                Narg
                http://www.seven-mountains.eu/

                Comment


                  #9
                  I am subscribed to Zoombapup

                  Which TUT was this in?

                  Narg
                  http://www.seven-mountains.eu/

                  Comment


                    #10
                    Player FOV is just a float I added, you can call it whatever you like. It gets it's value from the camera's default when right clicking.
                    If you wanted, and you know your fov is (90 by default), then just replace it with that. As in, where you have zero in the minus node, replace it with 90. Also, yo uhave the inputs reversed on that, presuming your timeline goes to a positive value.

                    edit: the only reason I done it like that, is that if your player can change their FOV in game settings for example the setup will still work.
                    But if your FOV is fixed, you could just do some thing like:
                    Click image for larger version

Name:	W1xjWDg.png
Views:	1
Size:	71.1 KB
ID:	1066793

                    The timeline goes from 90 to 40.
                    Last edited by Mosel3y; 02-20-2015, 08:20 AM.

                    Comment


                      #11
                      Cheers for reply

                      Works well. But somewhere I stuffed up up/down look. Shoot me now.


                      Narg
                      http://www.seven-mountains.eu/

                      Comment


                        #12
                        Fixed up look up and down.

                        But you can not move the camera while in ZOOM.

                        Not sure this will work. Thanks for the replies either way.

                        Narg
                        http://www.seven-mountains.eu/

                        Comment


                          #13
                          It shouldn't affect that, how is your input set up for look up and down?

                          Comment


                            #14
                            Mos: I stuffed up my look somehow in my backup. So reverted to original and fine.

                            Issue I have is no movement when in Zoom, and zoom not returning to normal view.



                            P.S. How to you control how far the zoom in?

                            Narg
                            Last edited by Narghile; 02-20-2015, 09:52 AM.
                            http://www.seven-mountains.eu/

                            Comment


                              #15
                              That timeline should not go from 0 to 40 if you are setting it directly like that, it should be from 90 at zero, to 40 at the end of the timeline (and then switch your inputs).

                              The lower your FOV, the more zoomed in you are. It should never be 0.

                              Comment

                              Working...
                              X