Announcement

Collapse
No announcement yet.

UMG Inventory Tutorial Help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    It seems everyone who followed the tutorial has some type of bug. Epic if you see this can you make a videos to fix these issues. All of the comments on the video are people asking for help.
    Last edited by Firezown; 02-16-2015, 06:29 PM.

    Comment


      #32
      Hi everyone,

      I am not at the office today, however I have added this to a list of bugs to test and will check into it tomorrow when I am back at the office with a computer that can properly run the editor (unfortunately my home computer is under-specced for development).
      Adam Davis | Marketplace Support | Epic Games
      How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

      Comment


        #33
        Ok, Thanks.

        Comment


          #34
          Originally posted by Adam Davis View Post
          Hi everyone,

          I am not at the office today, however I have added this to a list of bugs to test and will check into it tomorrow when I am back at the office with a computer that can properly run the editor (unfortunately my home computer is under-specced for development).
          Have you found a way to fix these issues?

          Comment


            #35
            Its been about a week and a half and i still have not managed to fix these two issues. I have re watched and followed the tutorial sever times but it all ends the same.

            My two problems are.

            1: The Action Text does not appear for the item.

            2: When i click Use/Drop nothing happens on either button. It does the same thing the cancel button does. Just closes the Action menu.

            (I fixed the freezing of the inventory by checking the box on Inventory Active.)

            Does anyone know how to fix this or have the same issues?.

            Comment


              #36
              I recently completed this "tutorial" as well. It was really bad. Very little was actually explained. They only thing you learn by watching that series is how to follow his directions. But like so many other people, I ran into numerous issues. Between almost every video he made changes to the blueprints and didn't mention them. less than half the variables that needed to be public were shown in the videos.

              Anyways, I eventually got it to work, just like in his video but I noticed an issue. I confirmed that the issue is not isolated to my BP's by downloading the completed tutorial project and seeing that it was there too.
              Basically, when you pull up the inventory you have to actually click somewhere on the screen for it to begin reacting to your mouse. Just opening the inventory and hovering the mouse does not change the icons to the hovering state, unless you click the mouse somewhere on the screen. The same is true when you close the inventory. You have to click before you regain control of your character. I suspect it is linked to the tip at the top left of the screen that pops up saying "Press Shift+F1 to gain mouse control" and "Click for Mouse Control" for you want to switch between the inventory and character control states. These messages are not anywhere in the blueprints. I thought they might be exclusive to the building phase of the project, but the issue is still present on the built .exe game.

              Comment


                #37
                Originally posted by R3volve View Post
                I recently completed this "tutorial" as well. It was really bad. Very little was actually explained. They only thing you learn by watching that series is how to follow his directions. But like so many other people, I ran into numerous issues. Between almost every video he made changes to the blueprints and didn't mention them. less than half the variables that needed to be public were shown in the videos.

                Anyways, I eventually got it to work, just like in his video but I noticed an issue. I confirmed that the issue is not isolated to my BP's by downloading the completed tutorial project and seeing that it was there too.
                Basically, when you pull up the inventory you have to actually click somewhere on the screen for it to begin reacting to your mouse. Just opening the inventory and hovering the mouse does not change the icons to the hovering state, unless you click the mouse somewhere on the screen. The same is true when you close the inventory. You have to click before you regain control of your character. I suspect it is linked to the tip at the top left of the screen that pops up saying "Press Shift+F1 to gain mouse control" and "Click for Mouse Control" for you want to switch between the inventory and character control states. These messages are not anywhere in the blueprints. I thought they might be exclusive to the building phase of the project, but the issue is still present on the built .exe game.
                I downloaded the project and checked everything and my stuff is exactly the same as the project. What issues did you have and how did you fix them?.

                Comment


                  #38
                  Originally posted by Firezown View Post
                  I downloaded the project and checked everything and my stuff is exactly the same as the project. What issues did you have and how did you fix them?.
                  Too many to count I am afraid. I did not keep track.
                  Most of the issues I fixed by reading the comments on the youtube page. Others, I just had to redo steps because they simply didn't function, probably due to a bug. For example when you make the animation for the inventory sliding out, the "Auto key frame" button was grayed out, and I had to go back a step, delete and re-create the animation for it to become clickable. The engine still feels like a beta to me, but according to the wiki, it has been in development for 8 years or something. If there was a better alternative out there I would use it. Unity is poorly optimized, looks like ****, runs like ****. All the unity powered games on android look awful, run poorly, and destroy your battery. Cryengine as a service is worse. You can't do anything with it except level design. Everything else with it is broken and undocumented. As much as it sucks, Unreal is the only option for people that want to make a game worth playing.

                  Comment


                    #39
                    Hi everyone,

                    I am sincerely sorry I haven't been able to look into this yet. Due to the crazy weather we've been having here at the main office my schedule and tasks have been in constant flux. As soon as I am able to fit it in I will take a look at this and see what I can do.
                    Adam Davis | Marketplace Support | Epic Games
                    How to report a bug? | Installation & Setup issues? | Answerhub Bug Reports | Twitter

                    Comment


                      #40
                      Don't know if i'm blowing my own trumpet here but you can lay down the red carpet as I have arrived with the fix. So after seeing this thread for about a week I decided to download the demo. After about 10 minutes of figuring out how it all works I believe I know what the problem is.

                      Check your inventory slot numbers start from 0. Failure to do so will cause it to get the information in the next slot (which if you only have 1 item) would be empty causing the action text not to display and the drop/action buttons to not work.

                      slot 1 will be 0, 2 will be 1, 3 will be 2 and so. Hope this helps.

                      Click image for larger version

Name:	InventoryFix.png
Views:	1
Size:	47.9 KB
ID:	1067384
                      Looking for blueprint tutorials? Then visit my blog... voxagon

                      Comment


                        #41
                        Originally posted by pattym View Post
                        Don't know if i'm blowing my own trumpet here but you can lay down the red carpet as I have arrived with the fix. So after seeing this thread for about a week I decided to download the demo. After about 10 minutes of figuring out how it all works I believe I know what the problem is.

                        Check your inventory slot numbers start from 0. Failure to do so will cause it to get the information in the next slot (which if you only have 1 item) would be empty causing the action text not to display and the drop/action buttons to not work.

                        slot 1 will be 0, 2 will be 1, 3 will be 2 and so. Hope this helps.

                        [ATTACH=CONFIG]27544[/ATTACH]
                        Thank you! That has fixed everything. It all works fine now !

                        Comment


                          #42
                          Not sure if anybody else has encountered this problem. Running through this tutorial, I get stuck on creating the keyframes. The AutoKey doesn't generate they keyframes. I have tried toggling the Autokey, deleting/recreating the animation, closing and reopening the editor. Everything I try to move the Inventory Menu off screen the keyframe won't get created. Everything else works pretty smoothly. I am on version 4.7.3

                          Comment

                          Working...
                          X