Announcement

Collapse
No announcement yet.

Custom Event Call not working on the client

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom Event Call not working on the client

    Hi,

    I have a custom event set up in a character blueprint and an event in player controller which fires this custom event. On the server the event call works perfectly fine, but on the client the custom event does not launch. I debugged the player controller blueprint on the client and the call node is executed, but does nothing. Here are screenshots of the blueprints:

    In MyPlayerController:
    Click image for larger version

Name:	Screen Shot 02-11-15 at 01.25 PM.PNG
Views:	1
Size:	104.3 KB
ID:	1144127
    In CubeUnitBlue blueprint:
    Click image for larger version

Name:	Screen Shot 02-11-15 at 01.31 PM.PNG
Views:	1
Size:	84.1 KB
ID:	1144128

    Does anybody know solution to this issue?

    #2
    Are you sure the client finds instances of CubeUnitBlue, are they replicated? Try printing the array length of OutActors. Is CursorOver false on the client? Try printing an error message if its true. Thats all I can come up with seeing your graphs.
    Journeyman's Minimap - Available on Marketplace - Forum topic - Video

    Comment


      #3
      I debugged everything thoroughly and the event node was simply not fired for some reason. There were instances of CubeUnitBlue on the client and the CursorOver was false.

      But when I created a new project to reproduce the issue for a Bug Report and opened my previous project once more, the problem went away. I am still completely unaware what might have caused it.

      Comment

      Working...
      X