Announcement

Collapse
No announcement yet.

2 Actor synced montage. How to align Actors to start?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    2 Actor synced montage. How to align Actors to start?

    I have 2 animations created for a synced attack and defend sequence. It is meant that if both actors start on the same location. In the montage they are set to root motion.

    They play in time, the problem is the location.

    When I Set Actor location, the defender to the attackers, if I set the sweep checkbox it is in front, and if I don't, or I teleport the defender disappears.

    I don't mind a quick teleport of only a few units, will hide it with a particle effect. But, I need to either get them lined up right.

    How are you supposed to do this?

    The other thing I tried was set there collision to ignore pawn, but that doesn't seem to make a difference.

    #2
    The way I do it is tell the enemy actor to just disable all its collision, then attach it to the player actor (or whoever controls the montage). You only need the root motion on the player/attacker, and the defender's root motion (as I assume it is just a mirror image of the player's, to keep their roots aligned) can be entirely disregarded/zeroed out since it will be handled by tracking the player as a child.

    If that doesn't work for your specific circumstances (i.e. the two actors' roots begin at the same point but eventually separate), you'll need to make sure you set up your collision such that the two actors CANNOT collide (capsule-to-capsule won't be enough if the capsules can also collide with the skeletal physics asset, for instance).

    Comment


      #3
      Ok thank you, what BP Node do you turn the collision off with, and from what component please?

      I thought that may have been the problem but got hung up trying to cast to the PhysicsComponent.

      Comment


        #4
        You should be able to disable all collision with the "Disable Actor Collision" node.

        You can also set Enable Collision on a per-component basis by dragging off of the component var.

        Comment


          #5
          Thanks that did it and it's working right now. The Set Collision Enabled node, and then Attach Actor to Actor with Snap to Target worked great.

          Comment


            #6
            Just a question. Are you planning on networking this ever?

            Comment

            Working...
            X