Announcement

Collapse
No announcement yet.

Why pawn is not moving

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why pawn is not moving

    I have created a GameMode, Pawn and added Movement in my Pawn BP Graph. Then changed the game mode and assigned new Pawn in the default pawn class. Nothing happens when I move mouse or use keyboard.

    Pawn BP
    Click image for larger version

Name:	movement.PNG
Views:	1
Size:	88.0 KB
ID:	1142587


    Input Settings (my key mapping is not logically correct as you can see S is assigned instead of D for movement and also repeated for turning but this shold be not the problem as the same input config working for Character class)

    Click image for larger version

Name:	input.PNG
Views:	1
Size:	17.6 KB
ID:	1142588

    Is it must to have any components in my Pawn class? because there are no components added (not even the camera) in my pawn class. Is there anything I have missed? I have also tried by toggling Use Controller Yaw/Pitch/Roll.
    Last edited by NotReal1; 01-05-2015, 09:59 AM.

    #2
    I believe the base Pawn class does not apply any movement when using AddMovementInput. From the docs:

    https://docs.unrealengine.com/latest...put/index.html

    Try using DefaultPawn as the parent class of your Pawn BP instead of Pawn and see if this fixes your issue.

    If you use DefaultPawn, make sure to set bAddDefaultMovementBindings to false, otherwise it will setup a bunch of input mappings for you automatically which may cause confusion.
    Last edited by Syntaks; 01-05-2015, 10:55 AM.

    Comment


      #3
      Originally posted by Syntaks View Post

      Try using DefaultPawn as the parent class of your Pawn BP instead of Pawn and see if this fixes your issue.
      How do I change parent class in Blue Print? I am not using C++.

      Update: Never mind. I got it. I can choose parent class when I am creating. So noob I am :P
      Last edited by NotReal1; 01-05-2015, 01:01 PM.

      Comment


        #4
        Here is how you can change the parent class of an existing BP:







        And here is where you can disable Add Default Movement Bindings:







        The input you send to AddMovementInput is affected by the Floating Pawn Movement section as well.
        Attached Files
        Last edited by Syntaks; 01-05-2015, 02:16 PM.

        Comment


          #5
          Thanks Syntaks. I actually created a new pawn and chosen parent class from the scroll list. Using Blueprint Props was much easy way
          I have also unchecked Use Default Mouse Bindings but it didnt worked. The probloem was I did not bind Input keys properly in new project. Thanks for you help

          Comment


            #6
            Wow, you got me Syntaks

            Comment

            Working...
            X