Announcement

Collapse
No announcement yet.

Can only have one timeline?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • started a topic Can only have one timeline?

    Can only have one timeline?

    I've been beating my head against the wall trying to figure out why my timeline wont run.

    It appears I can only have one per blueprint or something? There's no warning or anything, every other timeline I place simply does not run when told to. The other ones aren't currently running.

    I can't have all my functions in a single timeline, how do you get around this?

  • replied
    Hey, it's 2019 and this is still an issue in the latest version :\

    Leave a comment:


  • replied
    For the sake of resolution, I posted the bug report and it's a known issue. Work around is to have a get timeline -> is playing that is connected to nothing or use an event to make it play/stop.

    Leave a comment:


  • replied
    It doesn't appear to be an issue with having two timelines running.

    It's an issue with for some reason the new timelines being created do not exist when called. Eg. I make a timeline, I get timeline then query f.ex 'is playing' and it errors saying that the timeline is 'None'.

    This doesn't occur in new projects, but I still need to know how to fix it so it doesn't occur in mine.

    Error Accessed None 'RunTimeline' from node Set Max Walk Speed in blueprint PController
    This is what it says when I query if RunTimeline is playing.

    Edit2:

    Found the problem. Using a get on a timeline in a function doesn't work for queries.

    If I query a timeline for 'is playing' without even executing anything related to it, it allows me to affect the timeline from within a function. If not, I can't.

    I'll post in bug report.
    Last edited by Vaei; 12-23-2014, 04:29 PM.

    Leave a comment:


  • replied
    Hello,
    I just did a try in a 4.6.1 fps template project two timelines sliding a mesh in same blueprint and it works. Try with a blank new project and if you have the same issue it may be your update of the version of the engine, if not, maybe your project been bugged by upgrade.
    Last edited by Fen; 12-23-2014, 04:08 PM. Reason: typo

    Leave a comment:


  • replied
    All new timelines when using 'get' on the timeline returns None. Is this a bug in UE4.6?

    It thinks the timeline doesn't exist.

    Leave a comment:


  • replied
    Originally posted by Jacky View Post
    You can run more than one Timeline in the same BP. Can you post a screenshot of your BP please?
    That doesn't appear to be the case. Two identical timelines, when I switch which one it is trying to call the other wont work.

    I have tried making other timelines. Only the SheathingTimeline ever plays.

    I'm using UE4.6

    Edit: Just noticed one of my other timelines play. It feels like the new timelines being made are corrupted or something.

    Click image for larger version

Name:	timelines.jpg
Views:	1
Size:	90.9 KB
ID:	1064487

    Click image for larger version

Name:	timelines2.jpg
Views:	1
Size:	85.6 KB
ID:	1064488
    Last edited by Vaei; 12-23-2014, 03:15 PM.

    Leave a comment:


  • replied
    You can run more than one Timeline in the same BP. Can you post a screenshot of your BP please?

    Leave a comment:

Working...
X