Announcement

Collapse
No announcement yet.

Launch character/Set Velocity not working correctly with AI Move to

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I used stop movement immediately and it works pretty good.

    Leave a comment:


  • replied
    Hey that Works thanks. You don't even need timers, Though you cannot combine this with root motion, root motion overrides the Force and so the velovity i belive.
    Last edited by Neongho; 03-31-2017, 04:00 AM.

    Leave a comment:


  • replied
    I have a work around - change movement mode to falling right after AI launch. (CharacterMovement:SetMovementMode)

    Leave a comment:


  • replied
    lil' Bump,

    Perhaps it's possible to make a custom "move to" method in blueprint? I wouldn't know how to begin having it use the navmesh though

    Leave a comment:


  • Launch character/Set Velocity not working correctly with AI Move to

    Hey all,

    I'm working on a dungeon crawler type game and have set up a system for knocking enemies backwards when you hit them with your sword by using launch character. This works great for when the player is hit or a stationary enemy but if the enemy is using the "move to" node (e.g. for random wandering, chasing the player) it messes with the launch command/set velocity. I found this post in the unreal answers from a few months ago which I believe shows the same issue I'm having...

    https://answers.unrealengine.com/que...or-overri.html

    Can anyone think of a possible work around? Right now I have it teleport the enemy instead and set it's velocity to 0. This is ok to test gameplay but comes with it's own issues (can accidentally teleport them through walls + doesn't look quite right)

    any help would be much appreciated!
    Last edited by mrcrocker; 11-14-2014, 12:24 PM. Reason: spelling
Working...
X