Announcement

Collapse
No announcement yet.

UMG: Mouse Move and Mouse Button Up event issue?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by NickDarnell View Post
    Took a quick look, make sure you are capturing the mouse on mouse down. None of your function overrides are properly returning a handled state. Also you should be using the events coming off the border, not the overrides for the user widget unless you want the whole surface of the user widget to respond to them. I think some parent widget is capturing the mouse because you're not, and so you stop getting mouse events while it's pressed.

    You need to use the Handled node, followed by the Capture Mouse node off the handled node.

    On mouse up make sure you do Handled->ReleaseMouseCapture
    If you ever happen to be in germany ... you'll get a shitload of cookies from me for that info


    Edit:
    First test looks good so far... good thing this works in fullscreen as well
    Last edited by ruohki; 11-16-2014, 12:49 PM.

    Leave a comment:


  • replied
    Originally posted by NickDarnell View Post
    Took a quick look, make sure you are capturing the mouse on mouse down. None of your function overrides are properly returning a handled state. Also you should be using the events coming off the border, not the overrides for the user widget unless you want the whole surface of the user widget to respond to them. I think some parent widget is capturing the mouse because you're not, and so you stop getting mouse events while it's pressed.

    You need to use the Handled node, followed by the Capture Mouse node off the handled node.

    On mouse up make sure you do Handled->ReleaseMouseCapture
    it's working now.
    I need to return Handled state as you said.
    Thanks.

    @LHutz,
    If you have the same issue, just return a Handled state on the event function.

    Leave a comment:


  • replied
    Originally posted by NickDarnell View Post
    Took a quick look, make sure you are capturing the mouse on mouse down. None of your function overrides are properly returning a handled state. Also you should be using the events coming off the border, not the overrides for the user widget unless you want the whole surface of the user widget to respond to them. I think some parent widget is capturing the mouse because you're not, and so you stop getting mouse events while it's pressed.

    You need to use the Handled node, followed by the Capture Mouse node off the handled node.

    On mouse up make sure you do Handled->ReleaseMouseCapture
    Hi! Can you please provide a quick screenshot with the ideal set up? I'm having this same issue.

    Leave a comment:


  • replied
    Took a quick look, make sure you are capturing the mouse on mouse down. None of your function overrides are properly returning a handled state. Also you should be using the events coming off the border, not the overrides for the user widget unless you want the whole surface of the user widget to respond to them. I think some parent widget is capturing the mouse because you're not, and so you stop getting mouse events while it's pressed.

    You need to use the Handled node, followed by the Capture Mouse node off the handled node.

    On mouse up make sure you do Handled->ReleaseMouseCapture

    Leave a comment:


  • replied
    Will look into it for 4.6 - guessing it has something to do with hit-test flags.

    Leave a comment:


  • replied
    @NickDarnell
    Any news about this issue?

    Leave a comment:


  • replied
    Originally posted by NickDarnell View Post
    Can you put up a shot of what the designer looks like with the hierarchy expanded?
    Here it is, it's very simple:
    Click image for larger version

Name:	Hierarchy.jpg
Views:	1
Size:	436.3 KB
ID:	1057597

    Leave a comment:


  • replied
    Can you put up a shot of what the designer looks like with the hierarchy expanded?

    Leave a comment:


  • started a topic UMG: Mouse Move and Mouse Button Up event issue?

    UMG: Mouse Move and Mouse Button Up event issue?

    Hi,

    I want to know are these event work normals or are bugs?(4.5preview):

    1.Mouse Move event can't be fired if the mouse button is pressed,
    2.Mouse Button Up event seems only be fired if pressed twice button down.

    Here is the video:



    Thanks.
Working...
X