Announcement

Collapse
No announcement yet.

UE4 - AI keeps runnig after it hits a wall, why?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UE4 - AI keeps runnig after it hits a wall, why?

    Hi, I'm using "AI move to" node to make My AI to move from one point to the other, I'm not using behavior trees, but, after the AI chooses a point to reach in "reachable point radius", then "AI move to" makes it walk to that position, but if in between there is a rock, it keeps "running" trying to get to that point, it looks like it's doing the moonwalk next to a rock, AI does not stop moving until eventually the "AI move to" node fails, then it stops, I already tried avoidance, but it is not fixing the issue,

    What else can I do, to make it stop after AI hits something?
    Last edited by DraxFX; 11-24-2020, 03:33 AM.

    #2
    Hi, yep AI Move To doesn't automatically check if the character collides with something on its way to the destination it just follows a path shown to be possible by the Navmesh data. You can either make sure the rock has collision enabled and is higher than max step height for the agent then recalculate the nav data so the character walks round it. Or you could do some form of ray trace in front of the character to check if its about to hit something. Or maybe check the characters position every tick and if it didn't move between ticks cancel the movement..

    Comment


      #3
      Thanks, ticks are so dangerous for that

      I have a bigger issue right now, once I load a level with Streaming, Nav mesh stops working, so my character try to walk but they can only run the walk animation but the don't move, not sure why Streaming is causing this issue in the Nav Mesh, I even duplicated the nave mesh, one for persistent level, the other in the level but the problem persists... the biggest issue is that some of those AI do walk, so weird, from 20 AI, 5 walk... the other 15 can't.... not sure what to do, and setting the runtime to dynamic is going to impact the FPS way to much. If I test leaving and returning to the level "loading it" sometimes it works some time It doesn't.
      Last edited by DraxFX; 11-29-2020, 03:32 AM.

      Comment

      Working...
      X